aboutsummaryrefslogtreecommitdiff
path: root/graphics/cinepaint
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/cinepaint')
-rw-r--r--graphics/cinepaint/Makefile8
-rw-r--r--graphics/cinepaint/files/patch-plug-ins-png-png.c28
2 files changed, 32 insertions, 4 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 1af947b41ed0..1e9e85c9651d 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cinepaint
PORTVERSION= 0.22
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/CinePaint/CinePaint-${PORTVERSION}-1
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An editing tool used for painting and retouching of movies
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
lcms.1:${PORTSDIR}/graphics/lcms \
tiff.4:${PORTSDIR}/graphics/tiff \
ftgl.2:${PORTSDIR}/graphics/ftgl
@@ -27,7 +27,7 @@ USE_PYTHON= yes
USE_GNOME= gtk12
USE_GETTEXT= yes
USE_LDCONFIG= yes
-USE_XORG= xpm
+USE_XORG= xpm xi xext xft xinerama
MAN1= cinepaint.1 cinepainttool.1
@@ -38,7 +38,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1
OPTIONS= OPENEXR "Use OpenEXR" on
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
.include <bsd.port.pre.mk>
diff --git a/graphics/cinepaint/files/patch-plug-ins-png-png.c b/graphics/cinepaint/files/patch-plug-ins-png-png.c
new file mode 100644
index 000000000000..88a9234da8f0
--- /dev/null
+++ b/graphics/cinepaint/files/patch-plug-ins-png-png.c
@@ -0,0 +1,28 @@
+--- plug-ins/png/png.c.orig 2006-11-24 21:52:55.000000000 +0100
++++ plug-ins/png/png.c 2012-04-27 19:08:52.000000000 +0200
+@@ -59,6 +59,7 @@
+ #include "libgimp/stdplugins-intl.h"
+
+ #include <png.h> /* PNG library definitions */
++#include <pngpriv.h>
+
+ /*
+ * Constants...
+@@ -405,7 +406,7 @@
+ info = (png_infop)calloc(sizeof(png_info), 1);
+ #endif /* PNG_LIBPNG_VER > 88 */
+
+- if (setjmp (pp->jmpbuf))
++ if (setjmp (png_jmpbuf(pp)))
+ {
+ g_message ("%s\nPNG error. File corrupted?", filename);
+ return image;
+@@ -824,7 +825,7 @@
+ info = (png_infop)calloc(sizeof(png_info), 1);
+ #endif /* PNG_LIBPNG_VER > 88 */
+
+- if (setjmp (pp->jmpbuf))
++ if (setjmp (png_jmpbuf(pp)))
+ {
+ g_message ("%s\nPNG error. Couldn't save image", filename);
+ return 0;