aboutsummaryrefslogtreecommitdiff
path: root/graphics/clutter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/clutter/Makefile')
-rw-r--r--graphics/clutter/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/clutter/Makefile b/graphics/clutter/Makefile
index 19138147f06a..1cd758a06b73 100644
--- a/graphics/clutter/Makefile
+++ b/graphics/clutter/Makefile
@@ -3,11 +3,11 @@
# Whom: Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/clutter/Makefile,v 1.1 2010/07/15 14:48:21 kwm Exp $
+# $MCom: ports/graphics/clutter/Makefile,v 1.34 2010/09/24 16:35:42 kwm Exp $
#
PORTNAME= clutter
-PORTVERSION= 1.2.12
+PORTVERSION= 1.4.0
CATEGORIES= graphics
MASTER_SITES= GNOME \
http://www.clutter-project.org/sources/${PORTNAME}/${PORTVERSION:R}/
@@ -15,15 +15,19 @@ MASTER_SITES= GNOME \
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL based interactive canvas library
+LIB_DEPENDS= json-glib-1.0.0:${PORTSDIR}/devel/json-glib
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_GMAKE= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:22
-USE_GNOME= pkgconfig gtk20 gnomehack ltverhack gnomeprefix
+USE_GNOME= pkgconfig gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
USE_GL= gl
USE_XORG= glproto x11 xfixes xdamage xcomposite xi
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-x --with-json=internal
+CONFIGURE_ARGS= --with-x --enable-conformance=no
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}