aboutsummaryrefslogtreecommitdiff
path: root/graphics/danpei/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/danpei/Makefile')
-rw-r--r--graphics/danpei/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/danpei/Makefile b/graphics/danpei/Makefile
new file mode 100644
index 000000000000..87eec5bccace
--- /dev/null
+++ b/graphics/danpei/Makefile
@@ -0,0 +1,28 @@
+# ports collection makefile for: danpei
+# Date created: 4 Fev 2005
+# Whom: Andrey V. Elsukov <bu7cher@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= danpei
+PORTVERSION= 2.9.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= danpei
+
+MAINTAINER= bu7cher@yandex.ru
+COMMENT= Image Viewer for X Window System with thumbnail preview feature
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+.if !defined(WITHOUT_IMAGEMAGICK)
+RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12 gdkpixbuf
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>