aboutsummaryrefslogtreecommitdiff
path: root/graphics/dataplot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dataplot/Makefile')
-rw-r--r--graphics/dataplot/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index ae56d5b493cd..d75748f5be65 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -29,14 +29,14 @@ MAXOBV?= 400000 # Change if you need more observations/variable
.include <bsd.port.options.mk>
-.if ((${ARCH}=="amd64") || (${ARCH}=="sparc64") || (${ARCH}=="ia64"))
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
FFLAGS+= -DDD -DI32 -fdefault-real-8 -fdefault-double-8
.else
FFLAGS+= -DSD -DI32 -fdefault-real-8 -fdefault-double-8
.endif
post-extract:
- @${INSTALL_DATA} ${FILESDIR}/Makefile.tmpl ${WRKSRC}/Makefile
+ ${INSTALL_DATA} ${FILESDIR}/Makefile.tmpl ${WRKSRC}/Makefile
@${REINPLACE_CMD} \
-e 's;%%CFLAGS%%;${CFLAGS};' \
-e 's;%%FFLAGS%%;${FFLAGS};' \