aboutsummaryrefslogtreecommitdiff
path: root/graphics/dataplot/files/Makefile.tmpl
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dataplot/files/Makefile.tmpl')
-rw-r--r--graphics/dataplot/files/Makefile.tmpl326
1 files changed, 326 insertions, 0 deletions
diff --git a/graphics/dataplot/files/Makefile.tmpl b/graphics/dataplot/files/Makefile.tmpl
new file mode 100644
index 000000000000..750cac9af24a
--- /dev/null
+++ b/graphics/dataplot/files/Makefile.tmpl
@@ -0,0 +1,326 @@
+CFLAGS += -I%%LOCALBASE%%/include/gd -I%%X11BASE%%/include
+
+DEST = ${PREFIX}/bin
+
+EXTHDRS = %%X11BASE%%/include/X11/X.h \
+ %%X11BASE%%/include/X11/Xfuncproto.h \
+ %%X11BASE%%/include/X11/Xlib.h \
+ %%X11BASE%%/include/X11/Xmd.h \
+ %%X11BASE%%/include/X11/Xosdefs.h \
+ %%X11BASE%%/include/X11/Xutil.h \
+ %%LOCALBASE%%/include/gd/gd.h \
+ %%LOCALBASE%%/include/gd/gd_io.h
+
+HDRS =
+
+INSTALL = install
+
+LD = $(CC)
+
+LDFLAGS = -L%%LOCALBASE%%/lib -L%%X11BASE%%/lib
+
+LIBS = %%X11BASE%%/lib/libX11.a \
+ %%LOCALBASE%%/lib/libgd1.a \
+ %%LOCALBASE%%/lib/libpng.a \
+ /usr/lib/libz.a \
+ %%LOCALBASE%%/lib/libjpeg.a \
+ /usr/lib/libg2c.a \
+ /usr/lib/libm.a
+
+MAKEFILE = Makefile
+
+OBJS = dp1_linux.o \
+ dp2.o \
+ dp3.o \
+ dp4.o \
+ dp5.o \
+ dp6.o \
+ dp7.o \
+ dp8.o \
+ dp9.o \
+ dp10.o \
+ dp11.o \
+ dp12.o \
+ dp13.o \
+ dp14.o \
+ dp15.o \
+ dp16.o \
+ dp17.o \
+ dp18.o \
+ dp19.o \
+ dp20.o \
+ dp21.o \
+ dp22.o \
+ dp23.o \
+ dp24.o \
+ dp25.o \
+ dp26.o \
+ dp27.o \
+ dp28.o \
+ dp29.o \
+ dp30.o \
+ dp31.o \
+ dp32.o \
+ dp33.o \
+ dp34.o \
+ dp35.o \
+ dp36.o \
+ dp37.o \
+ dp38.o \
+ dp39.o \
+ dp40.o \
+ dp41.o \
+ dp42.o \
+ dp43.o \
+ dp44.o \
+ dp45.o \
+ dp46.o \
+ dpcalc.o \
+ dpdds2.o \
+ dpdds3.o \
+ dpdds.o \
+ edinit.o \
+ edmai2.o \
+ edsear.o \
+ edsub.o \
+ edwrst.o \
+ fit3b.o \
+ gl_src.o \
+ starpac.o \
+ tcdriv_nopc.o \
+ gd_src.o \
+ x11_src.o \
+ main.o
+
+PRINT = pr
+
+PROGRAM = dp
+
+SHELL = /bin/sh
+
+SRCS = dp1_linux.f \
+ dp2.f \
+ dp3.f \
+ dp4.f \
+ dp5.f \
+ dp6.f \
+ dp7.f \
+ dp8.f \
+ dp9.f \
+ dp10.f \
+ dp11.f \
+ dp12.f \
+ dp13.f \
+ dp14.f \
+ dp15.f \
+ dp16.f \
+ dp17.f \
+ dp18.f \
+ dp19.f \
+ dp20.f \
+ dp21.f \
+ dp22.f \
+ dp23.f \
+ dp24.f \
+ dp25.f \
+ dp26.f \
+ dp27.f \
+ dp28.f \
+ dp29.f \
+ dp30.f \
+ dp31.f \
+ dp32.f \
+ dp33.f \
+ dp34.f \
+ dp35.f \
+ dp36.f \
+ dp37.f \
+ dp38.f \
+ dp39.f \
+ dp40.f \
+ dp41.f \
+ dp42.f \
+ dp43.f \
+ dp44.f \
+ dp45.f \
+ dp46.f \
+ dpcalc.f \
+ dpdds2.f \
+ dpdds3.f \
+ dpdds.f \
+ edinit.f \
+ edmai2.f \
+ edsear.f \
+ edsub.f \
+ edwrst.f \
+ fit3b.f \
+ gl_src.f \
+ starpac.f \
+ tcdriv_nopc.f \
+ gd_src.c \
+ x11_src.c \
+ main.f
+
+SYSHDRS = /usr/include/machine/_types.h \
+ /usr/include/machine/endian.h \
+ /usr/include/math.h \
+ /usr/include/stddef.h \
+ /usr/include/stdio.h \
+ /usr/include/stdlib.h \
+ /usr/include/strings.h \
+ /usr/include/sys/_sigset.h \
+ /usr/include/sys/_types.h \
+ /usr/include/sys/cdefs.h \
+ /usr/include/sys/select.h \
+ /usr/include/sys/timespec.h \
+ /usr/include/sys/types.h
+
+all: $(PROGRAM)
+
+$(PROGRAM): $(OBJS) $(LIBS)
+ @echo "Linking $(PROGRAM) ..."
+ @$(LD) $(LDFLAGS) $(OBJS) $(LIBS) -o $(PROGRAM)
+ @echo "done"
+
+clean:; @rm -f $(OBJS) core
+
+clobber:; @rm -f $(OBJS) $(PROGRAM) core tags
+
+depend:; @mkmf -f $(MAKEFILE)
+
+echo:; @echo $(HDRS) $(SRCS)
+
+index:; @ctags -wx $(HDRS) $(SRCS)
+
+install: $(PROGRAM)
+ @echo Installing $(PROGRAM) in $(DEST)
+ @-strip $(PROGRAM)
+ @if [ $(DEST) != . ]; then \
+ (rm -f $(DEST)/$(PROGRAM); $(INSTALL) $(PROGRAM) $(DEST)); fi
+
+print:; @$(PRINT) $(HDRS) $(SRCS)
+
+tags: $(HDRS) $(SRCS); @ctags $(HDRS) $(SRCS)
+###
+dp10.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCOHO.INC DPCOSU.INC DPCODA.INC \
+ DPCOGR.INC DPCOBE.INC DPCOST.INC DPCOFO.INC DPCOF2.INC DPCOS2.INC \
+ DPCOMC.INC
+dp11.o: DPCOPA.INC DPCOZZ.INC DPCOGR.INC DPCOBE.INC DPCOZI.INC DPCOHK.INC \
+ DPCODA.INC DPCOHO.INC DPCOF2.INC DPCOPC.INC DPCOST.INC DPCOSU.INC \
+ DPCOPM.INC
+dp12.o: DPCOPA.INC DPCOZZ.INC DPCOST.INC DPCOHO.INC DPCOHK.INC DPCODA.INC \
+ DPCOGR.INC DPCOBE.INC DPCONP.INC DPCODV.INC DPCOZ2.INC DPCOPC.INC \
+ DPCOFO.INC DPCOF2.INC DPCOSU.INC DPCOZI.INC DPCODE.INC
+dp13.o: DPCOGR.INC DPCOBE.INC DPCOM2.INC DPCOHO.INC DPCOPA.INC DPCOPC.INC \
+ DPCOZ2.INC DPCODA.INC DPCOZZ.INC DPCOHK.INC
+dp14.o: DPCOPA.INC DPCOZ2.INC DPCOGR.INC DPCOBE.INC DPCOF2.INC DPCOHK.INC \
+ DPCODA.INC DPCOZZ.INC DPCOHO.INC DPCOPC.INC DPCOWI.INC DPCONP.INC \
+ DPCODE.INC DPCOST.INC
+dp15.o: DPCOPA.INC DPCOF2.INC DPCOZZ.INC DPCOPC.INC DPCOHK.INC DPCODA.INC \
+ DPCOST.INC DPCOGR.INC DPCOBE.INC DPCOSU.INC DPCOHO.INC DPCOMC.INC
+dp16.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOZ2.INC DPCOHO.INC DPCOFO.INC \
+ DPCOF2.INC DPCOWI.INC DPCODV.INC DPCONP.INC DPCOPC.INC DPCO3D.INC \
+ DPCOGR.INC DPCOBE.INC DPCOSU.INC DPCOST.INC DPCOZZ.INC DPCOZI.INC \
+ DPCOZD.INC
+dp17.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC DPCOZI.INC DPCOHO.INC \
+ DPCOST.INC DPCOZ2.INC DPCOGR.INC DPCOBE.INC DPCOZD.INC DPCOSU.INC
+dp18.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC DPCOGR.INC DPCOBE.INC \
+ DPCOZI.INC DPCOS2.INC DPCOMC.INC DPCOPM.INC DPCOF2.INC
+dp19.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC DPCOF2.INC DPCOSU.INC \
+ DPCOFO.INC DPCOZI.INC DPCOHO.INC DPCOST.INC DPCOZD.INC DPCOZ2.INC \
+ DPCOBE.INC DPCOWI.INC DPCONP.INC
+dp1_linux.o: DPCOMC.INC DPCOHO.INC DPCOGR.INC DPCOF2.INC DPCOWI.INC \
+ DPCOBE.INC DPCOTR.INC
+dp2.o: DPCOPA.INC DPCOMC.INC DPCOHK.INC DPCOHO.INC DPCOCO.INC DPCOF2.INC \
+ DPCOCP.INC DPCODA.INC DPCOZZ.INC DPCOST.INC DPCONP.INC DPCODB.INC \
+ DPCOPC.INC DPCODG.INC DPCOSU.INC DPCOS2.INC DPCOTR.INC DPCOBE.INC \
+ DPCODV.INC DPCOWI.INC DPCOGR.INC
+dp20.o: DPCOF2.INC DPCOPA.INC DPCOHK.INC DPCOSU.INC DPCOST.INC DPCODA.INC \
+ DPCOZZ.INC DPCOZD.INC DPCOZI.INC DPCODV.INC DPCOGR.INC DPCOBE.INC \
+ DPCOZ2.INC DPCOHO.INC DPCOMC.INC DPCOPC.INC
+dp21.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC DPCOZ2.INC DPCOST.INC \
+ DPCOHO.INC DPCOZI.INC DPCODE.INC DPCOF2.INC
+dp22.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOZZ.INC DPCOPM.INC DPCOGR.INC \
+ DPCOBE.INC DPCOM2.INC DPCOSU.INC DPCOS2.INC DPCOHO.INC DPCOF2.INC \
+ DPCOMC.INC DPCOZ2.INC DPCOZI.INC
+dp23.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC DPCOF2.INC DPCOPC.INC \
+ DPCOST.INC DPCOGR.INC DPCOBE.INC DPCOSU.INC DPCOS2.INC
+dp24.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOFO.INC DPCOF2.INC DPCOHO.INC \
+ DPCOMC.INC DPCOZ2.INC
+dp25.o: DPCOFO.INC DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOMC.INC DPCOSU.INC \
+ DPCOHO.INC DPCOZZ.INC DPCOZ2.INC DPCOZI.INC DPCOZD.INC DPCOPM.INC \
+ DPCOF2.INC DPCOGR.INC DPCOBE.INC DPCODB.INC DPCOPC.INC DPCOSO.INC \
+ DPCONP.INC DPCOTR.INC DPCODG.INC DPCOCO.INC DPCO3D.INC DPCOST.INC
+dp26.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC
+dp27.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCOSU.INC DPCODA.INC DPCOF2.INC \
+ DPCOPC.INC DPCOPM.INC DPCOMC.INC DPCODB.INC DPCOFO.INC DPCOSO.INC \
+ DPCOGR.INC DPCONP.INC DPCOHO.INC DPCOTR.INC DPCOBE.INC DPCODG.INC \
+ DPCOCO.INC DPCO3D.INC DPCOST.INC DPCOZ2.INC
+dp28.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOFO.INC DPCOF2.INC DPCOHO.INC \
+ DPCOZZ.INC DPCOST.INC DPCOMC.INC DPCOSU.INC
+dp29.o: DPCOPA.INC DPCOZZ.INC DPCOZI.INC DPCOHK.INC DPCODA.INC DPCOHO.INC \
+ DPCOST.INC DPCOMC.INC DPCOSU.INC DPCOF2.INC DPCOPC.INC DPCOBE.INC \
+ DPCODB.INC
+dp3.o: DPCOMC.INC DPCOPA.INC DPCOZZ.INC DPCOZ2.INC DPCOHK.INC DPCOCP.INC
+dp30.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOZZ.INC DPCOSU.INC DPCOFO.INC \
+ DPCOF2.INC DPCOHO.INC DPCOZI.INC DPCOST.INC DPCOGR.INC DPCOBE.INC
+dp31.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCOSU.INC DPCODA.INC DPCOGR.INC \
+ DPCOBE.INC DPCOHO.INC
+dp32.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOZZ.INC DPCOZD.INC DPCOST.INC \
+ DPCOF2.INC DPCOZ2.INC DPCOHO.INC DPCOZI.INC DPCOSU.INC DPCOFO.INC \
+ DPCOGR.INC DPCOBE.INC DPCOTR.INC DPCOPC.INC DPCODE.INC
+dp36.o: DPCOCP.INC DPCOMC.INC DPCOBE.INC DPCOGR.INC DPCO3D.INC DPCOPA.INC \
+ DPCOPC.INC DPCOHO.INC
+dp37.o: DPCOMC.INC DPCOPA.INC DPCOZD.INC DPCOGR.INC DPCONP.INC DPCOBE.INC \
+ DPCODV.INC DPCOST.INC DPCOZ2.INC DPCOCT.INC DPCOZI.INC
+dp38.o: DPCOGR.INC DPCONP.INC DPCOBE.INC DPCODV.INC DPCOST.INC DPCOF2.INC \
+ DPCOCT.INC DPCOPA.INC DPCOZ2.INC DPCOHK.INC DPCOHO.INC DPCOPM.INC \
+ DPCOPC.INC
+dp39.o: DPCOGR.INC DPCOBE.INC DPCONP.INC DPCODV.INC DPCOST.INC DPCOPA.INC \
+ DPCOPC.INC DPCOCT.INC
+dp4.o: DPCOMC.INC DPCOPA.INC DPCOPC.INC DPCOGR.INC DPCOBE.INC DPCOCP.INC \
+ DPCOHK.INC DPCODA.INC DPCOHO.INC
+dp40.o: DPCOPA.INC DPCOZZ.INC DPCONP.INC DPCOGR.INC DPCOBE.INC DPCOMC.INC \
+ DPCODA.INC DPCOM2.INC DPCODB.INC DPCODE.INC DPCOSU.INC DPCOPC.INC \
+ DPCODV.INC DPCOST.INC DPCOPM.INC DPCOHK.INC DPCODG.INC DPCOS2.INC \
+ DPCOHO.INC DPCO3D.INC DPCOZ2.INC DPCOZI.INC
+dp41.o: DPCOPA.INC DPCOMC.INC DPCODB.INC DPCOHK.INC DPCOPC.INC DPCOSU.INC \
+ DPCODA.INC DPCOCO.INC DPCOHO.INC DPCO3D.INC DPCOF2.INC DPCODV.INC \
+ DPCODE.INC DPCOWI.INC DPCOFO.INC DPCODG.INC DPCOGR.INC DPCOST.INC
+dp42.o: DPCOPA.INC DPCOZ2.INC DPCOMC.INC DPCOF2.INC DPCOHK.INC DPCOZZ.INC \
+ DPCO3D.INC DPCOPC.INC DPCOGR.INC DPCOBE.INC DPCOSU.INC DPCOPM.INC \
+ DPCOCP.INC DPCOZD.INC DPCODV.INC
+dp43.o: DPCOPA.INC DPCOZ2.INC DPCOMC.INC DPCOHK.INC DPCOSU.INC DPCODA.INC \
+ DPCOHO.INC DPCOZZ.INC DPCOZI.INC DPCOZD.INC DPCOCP.INC
+dp44.o: DPCOGR.INC DPCOBE.INC DPCOMC.INC
+dp45.o: DPCOPA.INC DPCOMC.INC DPCOGR.INC DPCOBE.INC
+dp46.o: DPCOWI.INC DPCOHO.INC
+dp5.o: DPCOPA.INC DPCOZ2.INC DPCOMC.INC DPCOHK.INC
+dp6.o: DPCOMC.INC
+dp7.o: DPCOBE.INC DPCOMC.INC DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOPC.INC
+dp8.o: DPCOPA.INC DPCOZZ.INC DPCOHK.INC DPCODA.INC DPCOSU.INC DPCOST.INC \
+ DPCOS2.INC DPCOHO.INC DPCOMC.INC DPCOF2.INC DPCOZD.INC DPCOZI.INC \
+ DPCOGR.INC DPCOBE.INC DPCOZ2.INC
+dp9.o: DPCOPA.INC DPCOHK.INC DPCODA.INC DPCOZZ.INC DPCOZ2.INC DPCOZD.INC \
+ DPCOZI.INC DPCOSU.INC DPCOHO.INC DPCOST.INC DPCOMC.INC DPCOF2.INC \
+ DPCOGR.INC DPCOBE.INC
+dpdds.o: DPCOPA.INC DPCODD.INC DPCOZZ.INC DPCOHK.INC DPCOSU.INC DPCODA.INC
+dpdds2.o: DPCOPA.INC DPCODD.INC
+dpdds3.o: DPCOPA.INC DPCODD.INC DPCOZ2.INC
+edinit.o: DPCOPA.INC DPCOHO.INC DPCONP.INC EDCOMM.INC DPCOZI.INC DPCOZC.INC
+edmai2.o: DPCOPA.INC DPCOHO.INC DPCONP.INC EDCOMM.INC DPCOZI.INC DPCOZC.INC \
+ DPCODV.INC
+edsear.o: DPCOPA.INC EDCOMM.INC DPCOZI.INC DPCOZC.INC DPCONP.INC
+edsub.o: DPCOPA.INC EDCOMM.INC DPCOZI.INC DPCOZC.INC DPCONP.INC DPCOHO.INC \
+ DPCODV.INC
+edwrst.o: DPCOPA.INC EDCOMM.INC DPCOZI.INC DPCOZC.INC
+fit3b.o: DPCOPA.INC DPCOHO.INC DPCOMC.INC DPCOHK.INC DPCOSU.INC DPCODA.INC \
+ DPCOZZ.INC DPCOZ2.INC DPCOF2.INC DPCOZD.INC
+main.o: DPCOPA.INC DPCOMC.INC DPCODB.INC DPCOHK.INC DPCOPC.INC DPCOSU.INC \
+ DPCOS2.INC DPCODA.INC DPCOFO.INC DPCOF2.INC DPCOSO.INC DPCOGR.INC \
+ DPCONP.INC DPCOHO.INC DPCOTR.INC DPCOBE.INC DPCODG.INC DPCOCO.INC \
+ DPCO3D.INC DPCODV.INC DPCOST.INC DPCOCP.INC DPCODE.INC DPCOM2.INC \
+ DPCOZZ.INC DPCOZI.INC DPCOZD.INC DPCOZ2.INC DPCOWI.INC DPCODD.INC \
+ DPCOPM.INC
+starpac.o: DPCOMC.INC
+tcdriv_nopc.o: DPCODV.INC DPCONP.INC