aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-igeoportal
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/deegree-igeoportal')
-rw-r--r--graphics/deegree-igeoportal/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index 839daf9f7d7b..9c40f70752a9 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-igeoportal
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= igeoportal
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PORTNAME}-std_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Browser based client handling WMS, WFS, and proxy service
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,11 +30,13 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/igeoportal-std.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_igeoportal_documentation_en.pdf ${DOCSDIR}