aboutsummaryrefslogtreecommitdiff
path: root/graphics/dia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dia/Makefile')
-rw-r--r--graphics/dia/Makefile34
1 files changed, 15 insertions, 19 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index 8ea13df76cd9..69fd0575d9cb 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -13,30 +13,26 @@ MASTER_SITE_SUBDIR= stable/sources/dia
MAINTAINER= saper@system.pl
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- xml.5:${PORTSDIR}/textproc/libxml \
- gdk_imlib.5:${PORTSDIR}/graphics/imlib \
+LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml \
popt.0:${PORTSDIR}/devel/popt
-RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
-USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_X_PREFIX= yes
USE_GMAKE= yes
-
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --enable-gnome
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GTK_CONFIG="${GTK_CONFIG}" \
- GLIB_CONFIG="${GLIB_CONFIG}" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_IMLIB= yes
+WANT_GNOME= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
MAN1= dia.1
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS= --enable-gnome
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -48,4 +44,4 @@ post-install:
${SED} "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/dia.sh > ${WRKDIR}/dia.sh
${INSTALL_SCRIPT} ${WRKDIR}/dia.sh ${PREFIX}/bin/dia
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>