aboutsummaryrefslogtreecommitdiff
path: root/graphics/edje/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/edje/Makefile')
-rw-r--r--graphics/edje/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/graphics/edje/Makefile b/graphics/edje/Makefile
index 16f408c5460a..114adb74909a 100644
--- a/graphics/edje/Makefile
+++ b/graphics/edje/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= edje
-DISTVERSION= 1.0.1
-PORTREVISION= 1
+DISTVERSION= 1.1.0
PORTEPOCH= 2
CATEGORIES= graphics enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-05-25/base/
+ http://files.roorback.net/e17/2011-12-02/base/
MAINTAINER= magik@roorback.net
COMMENT= Edje is a complex graphical design and layout engine
+LICENSE= BSD
+
LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
-LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -31,11 +31,22 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+= --without-vim
+.if !defined(NOPORTEXAMPLES)
+CONFIGURE_ARGS+= --enable-install-examples
+.else
+CONFIGURE_ARGS+= --disable-install-examples
+.endif
+
post-patch:
@${REINPLACE_CMD} -E -e "/^SUBDIRS[[:space:]]+=/s/utils//" \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|= \$$(datadir)/\$$(PACKAGE)/examples|= $$(datadir)/examples/$$(PACKAGE)|' \
+ ${WRKSRC}/src/examples/Makefile.in
post-install:
-update-mime-database ${PREFIX}/share/mime
+.if defined(NOPORTEXAMPLES)
+ @${RMDIR} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>