aboutsummaryrefslogtreecommitdiff
path: root/graphics/eog-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/eog-plugins')
-rw-r--r--graphics/eog-plugins/Makefile57
-rw-r--r--graphics/eog-plugins/distinfo3
-rw-r--r--graphics/eog-plugins/pkg-descr2
-rw-r--r--graphics/eog-plugins/pkg-plist75
4 files changed, 137 insertions, 0 deletions
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
new file mode 100644
index 000000000000..aec0aa46cdca
--- /dev/null
+++ b/graphics/eog-plugins/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: eog-plugins
+# Date created: 28 August 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/graphics/eog-plugins/Makefile,v 1.5 2009/10/20 12:03:34 avl Exp $
+#
+
+PORTNAME= eog-plugins
+PORTVERSION= 2.28.1
+CATEGORIES= graphics gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Plug-ins for the Eye of GNOME image viewer application
+
+BUILD_DEPENDS= eog:${PORTSDIR}/graphics/eog
+RUN_DEPENDS= eog:${PORTSDIR}/graphics/eog
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20
+WANT_GNOME= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CHAMPLAIN) || \
+ (exists(${LOCALBASE}/lib/libchamplain-0.4.so)) || defined(WITH_CHAMPLIAN)
+LIB_DEPENDS+= champlain-0.4.1:${PORTSDIR}/graphics/libchamplain
+PLIST_SUB+= CHAMPLAIN=""
+.else
+PLUST_SUB+= CHAMPLAIN="@comment "
+.endif
+
+.if !defined(WITHOUT_EXIF) || (exists(${LOCALBASE}/lib/libexif.so.12) || \
+ defined(WITH_EXIF))
+LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
+PLIST_SUB+= EXIF=""
+.else
+PLIST_SUB+= EXIF="@comment "
+.endif
+
+.if ${HAVE_GNOME:Mpygnome2}!=""
+USE_GNOME+= pygnome2
+CONFIGURE_ARGS+=--enable-python
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/eog-plugins/distinfo b/graphics/eog-plugins/distinfo
new file mode 100644
index 000000000000..f93de94ff87c
--- /dev/null
+++ b/graphics/eog-plugins/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/eog-plugins-2.28.1.tar.bz2) = 570857f4f9a32df31c64e5410125f98c
+SHA256 (gnome2/eog-plugins-2.28.1.tar.bz2) = cc15a7da85ebbe77701484e038be620858f00ed8696f69c8824ea769e74b1bee
+SIZE (gnome2/eog-plugins-2.28.1.tar.bz2) = 307193
diff --git a/graphics/eog-plugins/pkg-descr b/graphics/eog-plugins/pkg-descr
new file mode 100644
index 000000000000..7eed446bbbff
--- /dev/null
+++ b/graphics/eog-plugins/pkg-descr
@@ -0,0 +1,2 @@
+EoG-plugins is a collection of plugins for use with the Eye of GNOME Image
+Viewer.
diff --git a/graphics/eog-plugins/pkg-plist b/graphics/eog-plugins/pkg-plist
new file mode 100644
index 000000000000..b91fe7e6ba82
--- /dev/null
+++ b/graphics/eog-plugins/pkg-plist
@@ -0,0 +1,75 @@
+%%CHAMPLAIN%%lib/eog/plugins/champlain.eog-plugin
+%%PYTHON%%lib/eog/plugins/console.py
+%%PYTHON%%lib/eog/plugins/console.pyc
+%%PYTHON%%lib/eog/plugins/console.pyo
+%%EXIF%%lib/eog/plugins/exif-display.eog-plugin
+%%EXIF%%lib/eog/plugins/exif-display/exif-display-config.ui
+%%EXIF%%lib/eog/plugins/exif-display/exif-display.ui
+lib/eog/plugins/fit-to-width.eog-plugin
+%%CHAMPLAIN%%lib/eog/plugins/libchamplain.la
+%%CHAMPLAIN%%lib/eog/plugins/libchamplain.so
+%%EXIF%%lib/eog/plugins/libexif-display.la
+%%EXIF%%lib/eog/plugins/libexif-display.so
+lib/eog/plugins/libfit-to-width.la
+lib/eog/plugins/libfit-to-width.so
+%%PYTHON%%lib/eog/plugins/pythonconsole.eog-plugin
+%%PYTHON%%lib/eog/plugins/pythonconsole.py
+%%PYTHON%%lib/eog/plugins/pythonconsole.pyc
+%%PYTHON%%lib/eog/plugins/pythonconsole.pyo
+%%PYTHON%%lib/eog/plugins/slideshowshuffle.eog-plugin
+%%PYTHON%%lib/eog/plugins/slideshowshuffle.py
+%%PYTHON%%lib/eog/plugins/slideshowshuffle.pyc
+%%PYTHON%%lib/eog/plugins/slideshowshuffle.pyo
+share/locale/ar/LC_MESSAGES/eog-plugins.mo
+share/locale/as/LC_MESSAGES/eog-plugins.mo
+share/locale/be@latin/LC_MESSAGES/eog-plugins.mo
+share/locale/bg/LC_MESSAGES/eog-plugins.mo
+share/locale/bn_IN/LC_MESSAGES/eog-plugins.mo
+share/locale/ca/LC_MESSAGES/eog-plugins.mo
+share/locale/cs/LC_MESSAGES/eog-plugins.mo
+share/locale/da/LC_MESSAGES/eog-plugins.mo
+share/locale/de/LC_MESSAGES/eog-plugins.mo
+share/locale/el/LC_MESSAGES/eog-plugins.mo
+share/locale/en_GB/LC_MESSAGES/eog-plugins.mo
+share/locale/es/LC_MESSAGES/eog-plugins.mo
+share/locale/eu/LC_MESSAGES/eog-plugins.mo
+share/locale/fi/LC_MESSAGES/eog-plugins.mo
+share/locale/fr/LC_MESSAGES/eog-plugins.mo
+share/locale/gl/LC_MESSAGES/eog-plugins.mo
+share/locale/gu/LC_MESSAGES/eog-plugins.mo
+share/locale/hu/LC_MESSAGES/eog-plugins.mo
+share/locale/it/LC_MESSAGES/eog-plugins.mo
+share/locale/ja/LC_MESSAGES/eog-plugins.mo
+share/locale/kn/LC_MESSAGES/eog-plugins.mo
+share/locale/lt/LC_MESSAGES/eog-plugins.mo
+share/locale/mk/LC_MESSAGES/eog-plugins.mo
+share/locale/ml/LC_MESSAGES/eog-plugins.mo
+share/locale/mr/LC_MESSAGES/eog-plugins.mo
+share/locale/nb/LC_MESSAGES/eog-plugins.mo
+share/locale/or/LC_MESSAGES/eog-plugins.mo
+share/locale/pa/LC_MESSAGES/eog-plugins.mo
+share/locale/pl/LC_MESSAGES/eog-plugins.mo
+share/locale/pt/LC_MESSAGES/eog-plugins.mo
+share/locale/pt_BR/LC_MESSAGES/eog-plugins.mo
+share/locale/sl/LC_MESSAGES/eog-plugins.mo
+share/locale/sq/LC_MESSAGES/eog-plugins.mo
+share/locale/sv/LC_MESSAGES/eog-plugins.mo
+share/locale/ta/LC_MESSAGES/eog-plugins.mo
+share/locale/te/LC_MESSAGES/eog-plugins.mo
+share/locale/vi/LC_MESSAGES/eog-plugins.mo
+share/locale/zh_CN/LC_MESSAGES/eog-plugins.mo
+share/locale/zh_HK/LC_MESSAGES/eog-plugins.mo
+share/locale/zh_TW/LC_MESSAGES/eog-plugins.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+%%EXIF%%@dirrm lib/eog/plugins/exif-display