aboutsummaryrefslogtreecommitdiff
path: root/graphics/eos-movrec/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/eos-movrec/Makefile')
-rw-r--r--graphics/eos-movrec/Makefile43
1 files changed, 24 insertions, 19 deletions
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index 1cda1a13adac..58eff34df01e 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -2,39 +2,44 @@
# $FreeBSD$
PORTNAME= eos-movrec
-DISTVERSION= 0.3.1_beta
-PORTREVISION= 4
+DISTVERSION= 0.3.2_beta
CATEGORIES= graphics multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3_beta/ \
- SF/nemysisfreebsdp/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
-DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX}
-
-MAINTAINER= nemysis@gmx.ch
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
+
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Capture short movies with Canon DSLR camera
LICENSE= GPLv2
-LIB_DEPENDS= gphoto2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
USE_BZIP2= yes
USES= cmake pkgconfig
-USE_QT4= qmake_build moc_build rcc_build uic_build gui
+USE_DOS2UNIX= *.pro *.cpp *.h
+USE_QT4= corelib dbus declarative designer gui help iconengines imageformats \
+ moc_build multimedia network opengl phonon qmake_build qt3support \
+ rcc_build script scripttools sql qt3support uic_build webkit xml xmlpatterns
-PLIST_FILES= bin/eos_movrec \
- share/pixmaps/${PORTNAME}.png
+INSTALLS_ICONS= yes
+ICON_SIZES= 16x16 32x32 128x128 256x256 512x512
-DESKTOP_ENTRIES= "eos_movrec" "EOS Camera Movie Recorder" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "eos_movrec" "Graphics;Photography;Qt;" false
+DESKTOP_ENTRIES="EOS Camera Movie Recorder" "${COMMENT}" "${PORTNAME}" \
+ "eos_movrec" "Graphics;Photography;Qt;" false
NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,GLIBC,${OPSYS},' ${WRKSRC}/os_api.h
+ @${REINPLACE_CMD} -e 's|GLIBC|${OPSYS}|' ${WRKSRC}/os_api.h
+.for s in 16 32 128 256 512
+ @cd ${WRKSRC}/mac.icons && \
+ ${MV} ${s}.png ${PORTNAME}_${s}x${s}.png
+.endfor
post-install:
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKSRC}/mac.icons/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/32x32/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.include <bsd.port.mk>