aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-engine-sdl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/evas-engine-sdl/Makefile')
-rw-r--r--graphics/evas-engine-sdl/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/graphics/evas-engine-sdl/Makefile b/graphics/evas-engine-sdl/Makefile
new file mode 100644
index 000000000000..8b20ff8d253e
--- /dev/null
+++ b/graphics/evas-engine-sdl/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: evas-engine-sdl
+# Date created: 15 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= engine-sdl
+PORTVERSION= 0.9.9.042
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= evas-
+DISTNAME= evas-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A hardware accelerated canvas API (SDL engine)
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_FREETYPE2= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_EFL= evas
+USE_SDL= sdl
+BUILD_WRKSRC= ${WRKSRC}/src/modules/engines/software_sdl
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --disable-software-x11 \
+ --disable-software-16-x11 \
+ --disable-software-xcb \
+ --disable-directfb \
+ --enable-sdl \
+ --disable-buffer \
+ --disable-software-qtopia \
+ --disable-gl-x11 \
+ --disable-cairo-x11 \
+ --disable-xrender-x11 \
+ --disable-xrender-xcb \
+ --disable-glitz-x11 \
+ --disable-image-loader-gif \
+ --disable-image-loader-png \
+ --disable-image-loader-jpeg \
+ --disable-image-loader-eet \
+ --disable-image-loader-edb \
+ --disable-image-loader-tiff \
+ --disable-image-loader-xpm \
+ --disable-image-loader-svg
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
+ -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/evas-software-sdl.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.mk>