aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-engine-sdl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/evas-engine-sdl/Makefile')
-rw-r--r--graphics/evas-engine-sdl/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/evas-engine-sdl/Makefile b/graphics/evas-engine-sdl/Makefile
index 2bcac1cda73b..b397028e0f3f 100644
--- a/graphics/evas-engine-sdl/Makefile
+++ b/graphics/evas-engine-sdl/Makefile
@@ -2,32 +2,32 @@
# $FreeBSD$
PORTNAME= engine-sdl
-DISTVERSION= 1.1.0
+PORTVERSION= 1.7.4
CATEGORIES= graphics enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-12-02/base/
+ LOCAL/gblach/e17/
PKGNAMEPREFIX= evas-
-DISTNAME= evas-${DISTVERSION}
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= gblach@FreeBSD.org
COMMENT= A hardware accelerated canvas API (SDL engine)
LICENSE= BSD
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
USE_EFL= evas librt_hack libtool_hack
+USE_GNOME= gnomehack pkgconfig
USE_SDL= sdl
-BUILD_WRKSRC= ${WRKSRC}/src/modules/engines/software_sdl
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/modules/engines/software_16_sdl
INSTALL_WRKSRC= ${BUILD_WRKSRC}
.include "../evas-core/Makefile.inc"
-CONFIGURE_ARGS+= --enable-software-sdl
+CONFIGURE_ARGS+= --enable-software-16-sdl
post-patch:
@${REINPLACE_CMD} -E \