aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-engine-sdl
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/evas-engine-sdl')
-rw-r--r--graphics/evas-engine-sdl/Makefile16
-rw-r--r--graphics/evas-engine-sdl/distinfo4
-rw-r--r--graphics/evas-engine-sdl/pkg-plist8
3 files changed, 14 insertions, 14 deletions
diff --git a/graphics/evas-engine-sdl/Makefile b/graphics/evas-engine-sdl/Makefile
index 2bcac1cda73b..b397028e0f3f 100644
--- a/graphics/evas-engine-sdl/Makefile
+++ b/graphics/evas-engine-sdl/Makefile
@@ -2,32 +2,32 @@
# $FreeBSD$
PORTNAME= engine-sdl
-DISTVERSION= 1.1.0
+PORTVERSION= 1.7.4
CATEGORIES= graphics enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-12-02/base/
+ LOCAL/gblach/e17/
PKGNAMEPREFIX= evas-
-DISTNAME= evas-${DISTVERSION}
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= gblach@FreeBSD.org
COMMENT= A hardware accelerated canvas API (SDL engine)
LICENSE= BSD
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
USE_EFL= evas librt_hack libtool_hack
+USE_GNOME= gnomehack pkgconfig
USE_SDL= sdl
-BUILD_WRKSRC= ${WRKSRC}/src/modules/engines/software_sdl
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/modules/engines/software_16_sdl
INSTALL_WRKSRC= ${BUILD_WRKSRC}
.include "../evas-core/Makefile.inc"
-CONFIGURE_ARGS+= --enable-software-sdl
+CONFIGURE_ARGS+= --enable-software-16-sdl
post-patch:
@${REINPLACE_CMD} -E \
diff --git a/graphics/evas-engine-sdl/distinfo b/graphics/evas-engine-sdl/distinfo
index 0159d761d2d9..82db61be2731 100644
--- a/graphics/evas-engine-sdl/distinfo
+++ b/graphics/evas-engine-sdl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/evas-1.1.0.tar.bz2) = 7702a315dc22f4abc269f6a3ef2695b365a3eab4fd2fcdd07275e41221b03930
-SIZE (e17/evas-1.1.0.tar.bz2) = 9235732
+SHA256 (e17/evas-1.7.4.tar.bz2) = 53f3e58c876c38a6de9aa65ae660e526bc4671d05397c2c347f11e5e61f50a8f
+SIZE (e17/evas-1.7.4.tar.bz2) = 9365979
diff --git a/graphics/evas-engine-sdl/pkg-plist b/graphics/evas-engine-sdl/pkg-plist
index 811329701542..e09ded0b9fa5 100644
--- a/graphics/evas-engine-sdl/pkg-plist
+++ b/graphics/evas-engine-sdl/pkg-plist
@@ -1,8 +1,8 @@
-include/evas-1/Evas_Engine_SDL.h
-lib/evas/modules/engines/software_sdl/%%E17_ARCH%%/module.so
+include/evas-1/Evas_Engine_SDL_16.h
+lib/evas/modules/engines/software_16_sdl/%%E17_ARCH%%/module.so
libdata/pkgconfig/evas-software-sdl.pc
-@dirrm lib/evas/modules/engines/software_sdl/%%E17_ARCH%%
-@dirrm lib/evas/modules/engines/software_sdl
+@dirrm lib/evas/modules/engines/software_16_sdl/%%E17_ARCH%%
+@dirrm lib/evas/modules/engines/software_16_sdl
@dirrmtry lib/evas/modules/engines
@dirrmtry lib/evas/modules
@dirrmtry lib/evas