aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-pmaps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/evas-loader-pmaps/Makefile')
-rw-r--r--graphics/evas-loader-pmaps/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/graphics/evas-loader-pmaps/Makefile b/graphics/evas-loader-pmaps/Makefile
new file mode 100644
index 000000000000..38a79c34e611
--- /dev/null
+++ b/graphics/evas-loader-pmaps/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: evas-loader-pmaps
+# Date created: 15 May 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= loader-pmaps
+DISTVERSION= 1.0.0.beta
+CATEGORIES= graphics enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= evas-
+DISTNAME= evas-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A hardware accelerated canvas API (PMAPS loader)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= evas librt_hack libtool_hack
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+
+MAKEDIRS= ${WRKSRC}/src/modules/loaders/pmaps
+
+.include "../evas-core/Makefile.inc"
+CONFIGURE_ARGS+= --enable-image-loader-pmaps
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
+ -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
+ ${MAKEDIRS:S,$,/Makefile.in,}
+
+do-build:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
+
+do-install:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
+
+.include <bsd.port.mk>