aboutsummaryrefslogtreecommitdiff
path: root/graphics/exiftran/files/Makefile.exiftran
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/exiftran/files/Makefile.exiftran')
-rw-r--r--graphics/exiftran/files/Makefile.exiftran20
1 files changed, 20 insertions, 0 deletions
diff --git a/graphics/exiftran/files/Makefile.exiftran b/graphics/exiftran/files/Makefile.exiftran
new file mode 100644
index 000000000000..23e5ab7c7968
--- /dev/null
+++ b/graphics/exiftran/files/Makefile.exiftran
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+.PATH: ${.CURDIR}/../..
+PROG= exiftran
+SRCS= exiftran.c genthumbnail.c jpegtools.c filter.c op.c readers.c
+
+.PATH: ${.CURDIR}/../../jpeg/80
+SRCS+= transupp.c
+
+.PATH: ${.CURDIR}/../../rd
+SRCS+= read-jpeg.c
+
+LDADD= -L${PREFIX}/lib -ljpeg -lexif
+
+CFLAGS+= -I${PREFIX}/include -I${.CURDIR}/../../jpeg/80 \
+ -I${.CURDIR}/../.. -DHAVE_NEW_EXIF
+
+MAN=
+
+.include <bsd.prog.mk>