aboutsummaryrefslogtreecommitdiff
path: root/graphics/exiv2/files
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/exiv2/files')
-rw-r--r--graphics/exiv2/files/patch-src_CMakeLists.txt22
-rw-r--r--graphics/exiv2/files/patch-src_actions.cpp16
2 files changed, 0 insertions, 38 deletions
diff --git a/graphics/exiv2/files/patch-src_CMakeLists.txt b/graphics/exiv2/files/patch-src_CMakeLists.txt
deleted file mode 100644
index e6156750e053..000000000000
--- a/graphics/exiv2/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-FreeBSD does hat have -ldl.
-
-Instead of unconditionally passing 'dl' to the linker, use cmakes 'CMAKE_DL_LIBS' [1]
-which handles that properly on all systems.
-
-[1] https://cmake.org/cmake/help/v3.6/variable/CMAKE_DL_LIBS.html
-
---- src/CMakeLists.txt.orig 2017-03-27 09:04:12 UTC
-+++ src/CMakeLists.txt
-@@ -265,9 +265,9 @@ if ( MSVC )
- TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${SSH_LIBRARIES} )
- else()
- if ( UNIX AND NOT FREEBSD )
-- TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${EXPAT_LIBRARIES} )
-- TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${CURL_LIBRARIES} )
-- TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${SSH_LIBRARIES} )
-+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${CMAKE_DL_LIBS} ${EXPAT_LIBRARIES} )
-+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${CMAKE_DL_LIBS} ${CURL_LIBRARIES} )
-+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${CMAKE_DL_LIBS} ${SSH_LIBRARIES} )
- else()
- TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${EXPAT_LIBRARIES} )
- TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${CURL_LIBRARIES} )
diff --git a/graphics/exiv2/files/patch-src_actions.cpp b/graphics/exiv2/files/patch-src_actions.cpp
deleted file mode 100644
index 8d9505285216..000000000000
--- a/graphics/exiv2/files/patch-src_actions.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-FreeBSD does not know either
-* PTHREAD_RECURSIVE_MUTEX_INITIALIZER nor
-* PTHREAD_RECUSRIVE_MUTEX_INITIALIZER_NP
-
-
---- src/actions.cpp.orig 2017-03-08 20:42:28 UTC
-+++ src/actions.cpp
-@@ -2048,6 +2048,8 @@ namespace {
- #if defined(__APPLE__)
- /* This is the critical section object (statically allocated). */
- static pthread_mutex_t cs = PTHREAD_RECURSIVE_MUTEX_INITIALIZER;
-+ #elif defined(__FreeBSD__)
-+ static pthread_mutex_t cs = PTHREAD_MUTEX_INITIALIZER;
- #else
- static pthread_mutex_t cs = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
- #endif