aboutsummaryrefslogtreecommitdiff
path: root/graphics/f-spot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/f-spot/Makefile')
-rw-r--r--graphics/f-spot/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
index d3ac289ae810..70887d8eb72b 100644
--- a/graphics/f-spot/Makefile
+++ b/graphics/f-spot/Makefile
@@ -7,30 +7,32 @@
#
PORTNAME= f-spot
-PORTVERSION= 0.4.0
-PORTREVISION= 2
+PORTVERSION= 0.5.0.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
-MASTER_SITES= GNOME
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-MAINTAINER= bsd-sharp@googlegroups.com
+MAINTAINER= mono@FreeBSD.org
COMMENT= Personal photo management to the GNOME desktop
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
exif.12:${PORTSDIR}/graphics/libexif \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
-
-BROKEN= does not compile
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus \
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
USE_BZIP2= yes
USE_SQLITE= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gnomesharp20
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gnomedesktopsharp20
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -41,7 +43,8 @@ post-patch:
${WRKSRC}/src/f-spot.exe.config.in
@${REINPLACE_CMD} 's|target="libgphoto2.so.2"|target="libgphoto2.so"|g'\
${WRKSRC}/libgphoto2-sharp/libgphoto2-sharp.dll.config
- @${REINPLACE_CMD} 's|#!/bin/bash|#!/bin/sh|g' \
+ @${REINPLACE_CMD} 's|#!/bin/bash|#!/usr/bin/env bash|g' \
+ ${WRKSRC}/src/f-spot.in \
${WRKSRC}/tools/f-spot-import
@${REINPLACE_CMD} 's|G_GNUC_FUNCTION|G_STRLOC|g' \
${WRKSRC}/libfspot/f-jpeg-utils.c