aboutsummaryrefslogtreecommitdiff
path: root/graphics/f-spot
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/f-spot')
-rw-r--r--graphics/f-spot/Makefile20
-rw-r--r--graphics/f-spot/distinfo6
-rw-r--r--graphics/f-spot/files/patch-src_f-spot.in50
-rw-r--r--graphics/f-spot/pkg-plist57
4 files changed, 114 insertions, 19 deletions
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
index d15e4375e6ea..c1670d4dea92 100644
--- a/graphics/f-spot/Makefile
+++ b/graphics/f-spot/Makefile
@@ -3,16 +3,15 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.31 2006/10/03 02:37:44 tmclau02 Exp $
+# $Id: Makefile,v 1.39 2007/01/26 02:49:02 tmclau02 Exp $
#
PORTNAME= f-spot
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.3.2
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.3
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Personal photo management to the GNOME desktop
@@ -20,17 +19,16 @@ COMMENT= Personal photo management to the GNOME desktop
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
exif.12:${PORTSDIR}/graphics/libexif \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
-RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
+RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
USE_BZIP2= yes
USE_SQLITE= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack
-USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gnomesharp20
GNU_CONFIGURE= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -41,6 +39,8 @@ post-patch:
${WRKSRC}/src/f-spot.exe.config.in
@${REINPLACE_CMD} 's|target="libgphoto2.so.2"|target="libgphoto2.so"|g'\
${WRKSRC}/libgphoto2-sharp/libgphoto2-sharp.dll.config
+ @${REINPLACE_CMD} 's|#!/bin/bash|#!/bin/sh|g' \
+ ${WRKSRC}/tools/f-spot-import
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/graphics/f-spot/distinfo b/graphics/f-spot/distinfo
index cb490fbc6d59..70eef869cdab 100644
--- a/graphics/f-spot/distinfo
+++ b/graphics/f-spot/distinfo
@@ -1,3 +1,3 @@
-MD5 (f-spot-0.2.1.tar.bz2) = 75e9823a1cb32ebba43c533556d12bdb
-SHA256 (f-spot-0.2.1.tar.bz2) = e7ae11735d006a648c08aab300ed853c7426ac6bb6ce383ddf4ac3d3340e24e4
-SIZE (f-spot-0.2.1.tar.bz2) = 996972
+MD5 (f-spot-0.3.2.tar.bz2) = 1084f359ee7de5a4d24ed37a72b1342a
+SHA256 (f-spot-0.3.2.tar.bz2) = a1ffa2d3c97cc0727902021e44f8476d90d503cc2376f39b2e6a132e9aee78a4
+SIZE (f-spot-0.3.2.tar.bz2) = 1709277
diff --git a/graphics/f-spot/files/patch-src_f-spot.in b/graphics/f-spot/files/patch-src_f-spot.in
index 0f1ee54e83f4..b79bfdf277c3 100644
--- a/graphics/f-spot/files/patch-src_f-spot.in
+++ b/graphics/f-spot/files/patch-src_f-spot.in
@@ -1,14 +1,54 @@
---- src/f-spot.in.orig Thu Sep 7 17:56:20 2006
-+++ src/f-spot.in Mon Oct 2 22:35:40 2006
+--- src/f-spot.in.orig Mon Jan 15 04:53:32 2007
++++ src/f-spot.in Thu Jan 18 13:27:50 2007
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
prefix=@prefix@
exec_prefix=@exec_prefix@
-@@ -24,4 +24,4 @@
- echo "*** Running F-Spot in Debug Mode ***"
- esac
+@@ -16,23 +16,22 @@
+ [ -n "$FSPOT_PROFILE" ] && FSPOT_PROFILE="--profile=$FSPOT_PROFILE"
+
+ for arg in $*; do
+- case "x--debug" in ("x$arg")
+- FSPOT_DEBUG=$arg
+- esac
+-
+- case "x--trace=" in ("x${arg:0:8}")
+- FSPOT_TRACE=$arg
+- esac
+-
+- case "x--profile=" in ("x${arg:0:10}")
+- FSPOT_PROFILE=$arg
+- esac
+-
+- case "x--uninstalled" in ("x$arg")
+- echo "*** Running uninstalled f-spot ***"
+- EXE_TO_RUN="./f-spot.exe"
+- export MONO_PATH=../Tao/Tao.OpenGl:../Tao/Tao.OpenGl.Glu:../Tao/Tao.OpenGl.ExtensionLoader:../dbus-sharp:../dbus-sharp-glib:../google-sharp:../gnome-keyring-sharp:../FlickrNet:../SmugMugNet:../libgphoto2-sharp:../semweb:../glitz-sharp/src/:$MONO_PATH
+- esac
++ case "x$arg" in
++ x--debug)
++ FSPOT_DEBUG="$arg"
++ ;;
++ x--trace=*)
++ FSPOT_TRACE="$arg"
++ ;;
++ x--profile=*)
++ FSPOT_PROFILE="$arg"
++ ;;
++ x--uninstalled)
++ echo "*** Running uninstalled f-spot ***"
++ EXE_TO_RUN="./f-spot.exe"
++ export MONO_PATH=../Tao/Tao.OpenGl:../Tao/Tao.OpenGl.Glu:../Tao/Tao.OpenGl.ExtensionLoader:../dbus-sharp:../dbus-sharp-glib:../google-sharp:../gnome-keyring-sharp:../FlickrNet:../SmugMugNet:../libgphoto2-sharp:../semweb:../glitz-sharp/src/:$MONO_PATH
++ ;;
++ esac
+ done
+
+ if [ -n "$FSPOT_DEBUG" ]; then
+@@ -44,4 +43,4 @@
+ echo "** Running Mono with $MONO_OPTIONS **"
+ fi
-exec -a @PACKAGE@ mono $MONO_OPTIONS $EXE_TO_RUN "$@"
+exec mono $MONO_OPTIONS $EXE_TO_RUN "$@"
diff --git a/graphics/f-spot/pkg-plist b/graphics/f-spot/pkg-plist
index c86af40273f7..3f37ee491165 100644
--- a/graphics/f-spot/pkg-plist
+++ b/graphics/f-spot/pkg-plist
@@ -1,7 +1,18 @@
bin/f-spot
bin/f-spot-import
lib/f-spot/FlickrNet.dll
+lib/f-spot/NDesk.DBus.GLib.dll
+lib/f-spot/NDesk.DBus.GLib.dll.config
+lib/f-spot/NDesk.DBus.dll
+lib/f-spot/NDesk.Glitz.dll
lib/f-spot/SemWeb.dll
+lib/f-spot/SmugMugNet.dll
+lib/f-spot/Tao.OpenGl.ExtensionLoader.dll
+lib/f-spot/Tao.OpenGl.ExtensionLoader.dll.config
+lib/f-spot/Tao.OpenGl.Glu.dll
+lib/f-spot/Tao.OpenGl.Glu.dll.config
+lib/f-spot/Tao.OpenGl.dll
+lib/f-spot/Tao.OpenGl.dll.config
lib/f-spot/f-spot.exe
lib/f-spot/f-spot.exe.config
lib/f-spot/gnome-keyring-sharp.dll
@@ -20,16 +31,34 @@ lib/f-spot/libfspotjpegtran.so
lib/f-spot/libfspotjpegtran.so.0
lib/f-spot/libgphoto2-sharp.dll
lib/f-spot/libgphoto2-sharp.dll.config
+libdata/pkgconfig/f-spot.pc
libexec/gnome-screensaver/f-spot-screensaver
share/gnome-screensaver/themes/f-spot-screensaver.desktop
share/gnome/applications/f-spot-view.desktop
share/gnome/applications/f-spot.desktop
-share/gnome/pixmaps/f-spot-logo.png
+share/gnome/help/f-spot/C/f-spot.xml
+share/gnome/help/f-spot/C/figures/f-spot-fullscreen.png
+share/gnome/help/f-spot/C/figures/f-spot-slideshow.png
+share/gnome/help/f-spot/sv/f-spot.xml
+share/gnome/help/f-spot/sv/figures/f-spot-fullscreen.png
+share/gnome/help/f-spot/sv/figures/f-spot-slideshow.png
+share/icons/hicolor/16x16/apps/f-spot.png
+share/icons/hicolor/16x16/apps/f-spot.svg
+share/icons/hicolor/22x22/apps/f-spot.png
+share/icons/hicolor/22x22/apps/f-spot.svg
+share/icons/hicolor/24x24/apps/f-spot.png
+share/icons/hicolor/32x32/apps/f-spot.png
+share/icons/hicolor/32x32/apps/f-spot.svg
+share/icons/hicolor/48x48/apps/f-spot.png
+share/icons/hicolor/48x48/apps/f-spot.svg
+share/icons/hicolor/scalable/apps/f-spot.svg
+share/locale/ar/LC_MESSAGES/f-spot.mo
share/locale/bg/LC_MESSAGES/f-spot.mo
share/locale/ca/LC_MESSAGES/f-spot.mo
share/locale/cs/LC_MESSAGES/f-spot.mo
share/locale/da/LC_MESSAGES/f-spot.mo
share/locale/de/LC_MESSAGES/f-spot.mo
+share/locale/dz/LC_MESSAGES/f-spot.mo
share/locale/el/LC_MESSAGES/f-spot.mo
share/locale/en_CA/LC_MESSAGES/f-spot.mo
share/locale/en_GB/LC_MESSAGES/f-spot.mo
@@ -40,6 +69,7 @@ share/locale/fa/LC_MESSAGES/f-spot.mo
share/locale/fi/LC_MESSAGES/f-spot.mo
share/locale/fr/LC_MESSAGES/f-spot.mo
share/locale/gl/LC_MESSAGES/f-spot.mo
+share/locale/hi/LC_MESSAGES/f-spot.mo
share/locale/hu/LC_MESSAGES/f-spot.mo
share/locale/it/LC_MESSAGES/f-spot.mo
share/locale/ja/LC_MESSAGES/f-spot.mo
@@ -59,8 +89,33 @@ share/locale/th/LC_MESSAGES/f-spot.mo
share/locale/vi/LC_MESSAGES/f-spot.mo
share/locale/zh_CN/LC_MESSAGES/f-spot.mo
share/locale/zh_TW/LC_MESSAGES/f-spot.mo
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrm share/gnome/help/f-spot/sv/figures
+@dirrm share/gnome/help/f-spot/sv
+@dirrm share/gnome/help/f-spot/C/figures
+@dirrm share/gnome/help/f-spot/C
+@dirrm share/gnome/help/f-spot
@dirrmtry share/gnome-screensaver/themes
@dirrmtry share/gnome-screensaver
@dirrmtry libexec/gnome-screensaver