aboutsummaryrefslogtreecommitdiff
path: root/graphics/fortytwo
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/fortytwo')
-rw-r--r--graphics/fortytwo/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/fortytwo/Makefile b/graphics/fortytwo/Makefile
index d1f094138a96..65d0d24f0fad 100644
--- a/graphics/fortytwo/Makefile
+++ b/graphics/fortytwo/Makefile
@@ -13,12 +13,11 @@ COMMENT= Graph management system for GNUstep
LICENSE= LGPL21
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LOCAL_LIBS+= Encore:${ENCORE_PORT}
-USE_GNUSTEP_LOCAL_LIBS+= BDB:${FORTYTWO_BDB_PORT}
+USES= gnustep
+USE_GNUSTEP= back build
+
+LIB_DEPENDS= libEncore.so:${PORTSDIR}/devel/fortytwo-encore \
+ libBDB.so:${PORTSDIR}/databases/fortytwo-bdb
DEFAULT_LIBVERSION= 0.1
USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_BDB= 43+
@@ -26,8 +25,6 @@ USE_BDB= 43+
WRKSRC= ${WRKDIR}/FT-${PORTVERSION}
DOCSDIR= ${GNUSTEP_PREFIX}/Local/Library/Documentation/FT
-ENCORE_PORT?= devel/fortytwo-encore
-FORTYTWO_BDB_PORT?= databases/fortytwo-bdb
ADDITIONAL_OBJCFLAGS+= -I${BDB_INCLUDE_DIR}
ADDITIONAL_LDFLAGS+= -L${BDB_LIB_DIR}