aboutsummaryrefslogtreecommitdiff
path: root/graphics/frei0r
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/frei0r')
-rw-r--r--graphics/frei0r/Makefile26
-rw-r--r--graphics/frei0r/distinfo3
-rw-r--r--graphics/frei0r/pkg-descr17
3 files changed, 46 insertions, 0 deletions
diff --git a/graphics/frei0r/Makefile b/graphics/frei0r/Makefile
new file mode 100644
index 000000000000..a0e424ebd618
--- /dev/null
+++ b/graphics/frei0r/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: frei0r
+# Date created: 17 November 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frei0r
+PORTVERSION= 1.1.19
+DISTVERSIONPREFIX= plugins-
+CATEGORIES= graphics
+MASTER_SITES= http://frei0r.kexbox.org/download/source/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Minimalistic plugin API for video effects
+
+NO_BUILD= yes
+PLIST_FILES= include/frei0r.h
+
+post-extract:
+ @${FIND} ${WRKSRC} -name .arch-ids -or -name {arch} | ${XARGS} ${RM} -rf
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/spec/frei0r.h ${PREFIX}/include/
+
+.include <bsd.port.mk>
diff --git a/graphics/frei0r/distinfo b/graphics/frei0r/distinfo
new file mode 100644
index 000000000000..95287168b79a
--- /dev/null
+++ b/graphics/frei0r/distinfo
@@ -0,0 +1,3 @@
+MD5 (frei0r-plugins-1.1.19.tar.gz) = c6983200121b8f432d97f723cb615fa4
+SHA256 (frei0r-plugins-1.1.19.tar.gz) = 1a3b32ac49794c8b9b19eb0bf203c6aa75c69fb7198aad29d54a3e3279aadbea
+SIZE (frei0r-plugins-1.1.19.tar.gz) = 389120
diff --git a/graphics/frei0r/pkg-descr b/graphics/frei0r/pkg-descr
new file mode 100644
index 000000000000..13058ea3c9ae
--- /dev/null
+++ b/graphics/frei0r/pkg-descr
@@ -0,0 +1,17 @@
+Frei0r is a minimalistic plugin API for video sources and filters. The
+behaviour of the effects can be controlled from the host by simple
+parameters. The intent is to solve the recurring reimplementation or
+adaptation issue of standard effects.
+
+It is not meant as a generic API for all kinds of video applications.
+
+There is no support for the requirements of special application areas
+like non linear editors, hardware accelerated shader effects, and high
+precision video processing. These advanced issues are not even solved
+satisfactory for non cross application plugin apis and are still an
+evolving field.
+
+The frei0r API is not meant to be a competing standard to more
+ambitious efforts.
+
+WWW: http://www.piksel.org/frei0r