aboutsummaryrefslogtreecommitdiff
path: root/graphics/g2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/g2/Makefile')
-rw-r--r--graphics/g2/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/graphics/g2/Makefile b/graphics/g2/Makefile
index 0ca5c89ca5f9..f45a68f82688 100644
--- a/graphics/g2/Makefile
+++ b/graphics/g2/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: g2
-# Version required: 0.23
+# Version required: 0.30
# Date created: 16 July 1998
# Whom: Bill Fumerola <billf@chc-chimes.com>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/08/10 00:12:43 steve Exp $
#
-DISTNAME= g2-0.23
+DISTNAME= g2-0.30
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= libs/graphics
@@ -15,7 +15,15 @@ MAINTAINER= billf@chc-chimes.com
BUILD_DEPENDS= ${PREFIX}/lib/libgd.a:${PORTSDIR}/graphics/gd
-USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${PREFIX}/include/gd"
+
+post-patch:
+
+ ${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.pre_sed
+ ${CAT} ${WRKSRC}/Makefile.in.pre_sed | \
+ ${SED} -e 's#DIR = /usr#DIR = ${PREFIX}#g' \
+ >> ${WRKSRC}/Makefile.in
do-build:
cd ${WRKSRC} ; make depend ; make