aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gd1/Makefile')
-rw-r--r--graphics/gd1/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/graphics/gd1/Makefile b/graphics/gd1/Makefile
index e521758396ef..429848e4388a 100644
--- a/graphics/gd1/Makefile
+++ b/graphics/gd1/Makefile
@@ -13,11 +13,19 @@ MASTER_SITES= http://www.boutell.com/gd/http/ \
MAINTAINER= billf@FreeBSD.org
-LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
- ttf.4:${PORTSDIR}/print/freetype \
+LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png
+.if defined(WANT_X11)
+LIB_DEPENDS+= ttf.4:${PORTSDIR}/print/freetype \
Xpm.4:${PORTSDIR}/graphics/xpm
USE_XLIB= YES
+.endif
+
+pre-fetch:
+.if !defined(WANT_X11)
+ @${ECHO} -n "If you want to compile in X support use "
+ @${ECHO} "'make -DWANT_X11' instead"
+.endif
pre-install:
${MKDIR} ${PREFIX}/include/gd