aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd1
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gd1')
-rw-r--r--graphics/gd1/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/gd1/Makefile b/graphics/gd1/Makefile
index a6c514e9e9bd..321305c1c151 100644
--- a/graphics/gd1/Makefile
+++ b/graphics/gd1/Makefile
@@ -19,12 +19,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= ports@FreeBSD.org
-USE_FREETYPE2= yes
-BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+.if !exists(/usr/bin/bzip2)
+BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype:${PORTSDIR}/print/freetype2
+USE_FREETYPE2= yes
+
.if defined(WITH_X11)
USE_XLIB= yes
USE_XPM= yes
@@ -32,7 +35,7 @@ USE_XPM= yes
INSTALLS_SHLIB= yes
-post-extract:
+post-extract:
bzip2 -d < ${_DISTDIR}/gd_gif_in.c.bz2 > ${WRKSRC}/gd_gif_in.c
pre-everything: