aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd2
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gd2')
-rw-r--r--graphics/gd2/Makefile36
-rw-r--r--graphics/gd2/distinfo1
-rw-r--r--graphics/gd2/files/patch-ac146
-rw-r--r--graphics/gd2/pkg-comment1
-rw-r--r--graphics/gd2/pkg-descr23
-rw-r--r--graphics/gd2/pkg-plist20
6 files changed, 0 insertions, 227 deletions
diff --git a/graphics/gd2/Makefile b/graphics/gd2/Makefile
deleted file mode 100644
index 8d57c4be5dde..000000000000
--- a/graphics/gd2/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: gd
-# Date created: 27 Mar 1998
-# Whom: jeff@cetlink.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= gd
-PORTVERSION= 1.8.3
-CATEGORIES= graphics
-MASTER_SITES= http://www.boutell.com/gd/http/ \
- ftp://ftp.boutell.com/pub/boutell/gd/
-
-MAINTAINER= billf@FreeBSD.org
-
-LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
-.if defined(WITH_X11)
-LIB_DEPENDS+= ttf.4:${PORTSDIR}/print/freetype \
- Xpm.4:${PORTSDIR}/graphics/xpm
-
-USE_XLIB= yes
-.endif
-
-INSTALLS_SHLIB= yes
-
-pre-fetch:
-.if !defined(WITH_X11)
- @${ECHO} -n "If you want to compile in X support use "
- @${ECHO} "'make -DWITH_X11' instead"
-.endif
-
-pre-install:
- ${MKDIR} ${PREFIX}/include/gd
-
-.include <bsd.port.mk>
diff --git a/graphics/gd2/distinfo b/graphics/gd2/distinfo
deleted file mode 100644
index c49649bae22f..000000000000
--- a/graphics/gd2/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (gd-1.8.3.tar.gz) = ad0e7dd1dda2812dbaeaa9706c4be536
diff --git a/graphics/gd2/files/patch-ac b/graphics/gd2/files/patch-ac
deleted file mode 100644
index c54c2ab92621..000000000000
--- a/graphics/gd2/files/patch-ac
+++ /dev/null
@@ -1,146 +0,0 @@
---- Makefile.orig Thu May 18 13:39:18 2000
-+++ Makefile Sun May 21 00:55:38 2000
-@@ -5,3 +5,3 @@
- #compiler; get gcc if you are still using it).
--COMPILER=gcc
-+COMPILER=${CC}
-
-@@ -9,3 +9,3 @@
- #for your system.
--AR=ar
-+#AR=ar
-
-@@ -13,6 +13,10 @@
- #header files, uncomment this (default).
--CFLAGS=-O
-+#CFLAGS=-O
- #If you do have FreeType, libjpeg and/or Xpm fully installed, uncomment a
- #variation of this and comment out the line above. See also LIBS below.
--#CFLAGS=-O -DHAVE_XPM -DHAVE_JPEG -DHAVE_LIBTTF
-+.if defined(WITH_X11)
-+CFLAGS+=-DHAVE_XPM -DHAVE_JPEG -DHAVE_LIBTTF
-+.else
-+CFLAGS+=-DHAVE_JPEG
-+.endif
-
-@@ -25,3 +29,3 @@
-
--LIBS=-lm -lgd -lpng -lz
-+LIBS=-lm -lgd -lpng -lz -ljpeg
-
-@@ -35,3 +39,5 @@
-
--#LIBS=-lm -lgd -lpng -lz -ljpeg -lttf -lXpm -lX11
-+.if defined(WITH_X11)
-+LIBS+= -lttf -lXpm -lX11
-+.endif
-
-@@ -42,3 +48,6 @@
-
--INCLUDEDIRS=-I. -I/usr/local/include -I/usr/include/X11 -I/usr/X11R6/include/X11
-+INCLUDEDIRS=-I. -I${LOCALBASE}/include
-+.if defined(WITH_X11)
-+INCLUDEDIRS+=-I${LOCALBASE}/include/freetype -I${X11BASE}/include/X11 -I${X11BASE}/include
-+.endif
-
-@@ -50,12 +59,15 @@
- #on your system can't cause conflicts while building a new one.
--LIBDIRS=-L. -L/usr/local/lib -L/usr/lib/X11 -L/usr/X11R6/lib
-+LIBDIRS=-L. -L$(LOCALBASE)/lib
-+.if defined(WITH_X11)
-+LIBDIRS+=-L$(X11BASE)/lib
-+.endif
-
- #Location where libgd.a should be installed by "make install".
--INSTALL_LIB=/usr/local/lib
-+INSTALL_LIB=$(PREFIX)/lib
-
- #Location where .h files should be installed by "make install".
--INSTALL_INCLUDE=/usr/local/include
-+INSTALL_INCLUDE=$(PREFIX)/include/gd
-
- #Location where useful non-test programs should be installed by "make install".
--INSTALL_BIN=/usr/local/bin
-+INSTALL_BIN=$(PREFIX)/bin
-
-@@ -67,6 +79,6 @@
-
--VERSION=1.8.1
-+VERSION=1.8.2
-
--CC=$(COMPILER) $(INCLUDEDIRS)
--LINK=$(CC) $(LIBDIRS) $(LIBS)
-+CC+= $(INCLUDEDIRS)
-+#LINK=$(CC) $(LIBDIRS) $(LIBS)
-
-@@ -77,22 +89,29 @@
-
--all: libgd.a $(PROGRAMS)
-+.SUFFIXES: .c .so .o
-+
-+.c.so:
-+ ${CC} -fpic -DPIC ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}
-+
-+all: libgd.a libgd.so.1 $(PROGRAMS)
-
- install: libgd.a $(BIN_PROGRAMS)
-- sh ./install-item 644 libgd.a $(INSTALL_LIB)/libgd.a
-- sh ./install-item 755 pngtogd $(INSTALL_BIN)/pngtogd
-- sh ./install-item 755 pngtogd2 $(INSTALL_BIN)/pngtogd2
-- sh ./install-item 755 gdtopng $(INSTALL_BIN)/gdtopng
-- sh ./install-item 755 gd2topng $(INSTALL_BIN)/gd2topng
-- sh ./install-item 755 gd2copypal $(INSTALL_BIN)/gd2copypal
-- sh ./install-item 755 gdparttopng $(INSTALL_BIN)/gdparttopng
-- sh ./install-item 755 webpng $(INSTALL_BIN)/webpng
-- sh ./install-item 755 bdftogd $(INSTALL_BIN)/bdftogd
-- sh ./install-item 644 gd.h $(INSTALL_INCLUDE)/gd.h
-- sh ./install-item 644 gdcache.h $(INSTALL_INCLUDE)/gdcache.h
-- sh ./install-item 644 gd_io.h $(INSTALL_INCLUDE)/gd_io.h
-- sh ./install-item 644 gdfontg.h $(INSTALL_INCLUDE)/gdfontg.h
-- sh ./install-item 644 gdfontl.h $(INSTALL_INCLUDE)/gdfontl.h
-- sh ./install-item 644 gdfontmb.h $(INSTALL_INCLUDE)/gdfontmb.h
-- sh ./install-item 644 gdfonts.h $(INSTALL_INCLUDE)/gdfonts.h
-- sh ./install-item 644 gdfontt.h $(INSTALL_INCLUDE)/gdfontt.h
-+ $(INSTALL) -c -m 644 libgd.a $(INSTALL_LIB)/libgd.a
-+ $(INSTALL) -c -m 755 pngtogd $(INSTALL_BIN)/pngtogd
-+ $(INSTALL) -c -m 755 libgd.so.1 $(INSTALL_LIB)/libgd.so.1
-+ ln -sf libgd.so.1 $(INSTALL_LIB)/libgd.so
-+ $(INSTALL) -c -m 755 pngtogd2 $(INSTALL_BIN)/pngtogd2
-+ $(INSTALL) -c -m 755 gdtopng $(INSTALL_BIN)/gdtopng
-+ $(INSTALL) -c -m 755 gd2topng $(INSTALL_BIN)/gd2topng
-+ $(INSTALL) -c -m 755 gd2copypal $(INSTALL_BIN)/gd2copypal
-+ $(INSTALL) -c -m 755 gdparttopng $(INSTALL_BIN)/gdparttopng
-+ $(INSTALL) -c -m 755 webpng $(INSTALL_BIN)/webpng
-+ $(INSTALL) -c -m 755 bdftogd $(INSTALL_BIN)/bdftogd
-+ $(INSTALL) -c -m 644 gd.h $(INSTALL_INCLUDE)/gd.h
-+ $(INSTALL) -c -m 644 gdcache.h $(INSTALL_INCLUDE)/gdcache.h
-+ $(INSTALL) -c -m 644 gd_io.h $(INSTALL_INCLUDE)/gd_io.h
-+ $(INSTALL) -c -m 644 gdfontg.h $(INSTALL_INCLUDE)/gdfontg.h
-+ $(INSTALL) -c -m 644 gdfontl.h $(INSTALL_INCLUDE)/gdfontl.h
-+ $(INSTALL) -c -m 644 gdfontmb.h $(INSTALL_INCLUDE)/gdfontmb.h
-+ $(INSTALL) -c -m 644 gdfonts.h $(INSTALL_INCLUDE)/gdfonts.h
-+ $(INSTALL) -c -m 644 gdfontt.h $(INSTALL_INCLUDE)/gdfontt.h
-
-@@ -131,12 +150,15 @@
-
--libgd.a: gd.o gd_gd.o gd_gd2.o gd_io.o gd_io_dp.o gd_io_file.o gd_ss.o \
-+OBJS= gd.o gd_gd.o gd_gd2.o gd_io.o gd_io_dp.o gd_io_file.o gd_ss.o \
- gd_io_ss.o gd_png.o gd_jpeg.o gdxpm.o gdfontt.o gdfonts.o gdfontmb.o gdfontl.o \
-- gdfontg.o gdtables.o gdttf.o gdcache.o gdkanji.o wbmp.o gd_wbmp.o \
-- gd.h gdfontt.h gdfonts.h gdfontmb.h gdfontl.h gdfontg.h
-+ gdfontg.o gdtables.o gdttf.o gdcache.o gdkanji.o wbmp.o gd_wbmp.o
-+INCS= gd.h gdfontt.h gdfonts.h gdfontmb.h gdfontl.h gdfontg.h
-+
-+libgd.a: $(INCS) $(OBJS)
- rm -f libgd.a
-- $(AR) rc libgd.a gd.o gd_gd.o gd_gd2.o gd_io.o gd_io_dp.o \
-- gd_io_file.o gd_ss.o gd_io_ss.o gd_png.o gd_jpeg.o gdxpm.o \
-- gdfontt.o gdfonts.o gdfontmb.o gdfontl.o gdfontg.o \
-- gdtables.o gdttf.o gdcache.o gdkanji.o wbmp.o gd_wbmp.o
-+ $(AR) rc libgd.a $(OBJS)
- -ranlib libgd.a
-+
-+libgd.so.1: $(INCS) $(OBJS:.o=.so)
-+ $(CC) -shared -Wl,-x -Wl,-assert -Wl,pure-text -Wl,-soname,$@ -o $@ $(OBJS:.o=.so) $(LIBDIRS) $(LIBS)
-+ ln -sf libgd.so.1 libgd.so
-
diff --git a/graphics/gd2/pkg-comment b/graphics/gd2/pkg-comment
deleted file mode 100644
index e59d31d35dcd..000000000000
--- a/graphics/gd2/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A graphics library for fast PNG creation
diff --git a/graphics/gd2/pkg-descr b/graphics/gd2/pkg-descr
deleted file mode 100644
index f6ec333a65c6..000000000000
--- a/graphics/gd2/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION
-
- gd is a graphics library. It allows your code to quickly draw images
- complete with lines, arcs, text, multiple colors, cut and paste from
- other images, and flood fills, and write out the result as a .PNG file.
- This is particularly useful in World Wide Web applications, where .PNG
- is the format used for inline images.
-
- gd is not a paint program. If you are looking for a paint program, you
- are looking in the wrong place. If you are not a programmer, you are
- looking in the wrong place.
-
- gd does not provide for every possible desirable graphics operation.
- It is not necessary or desirable for gd to become a kitchen-sink
- graphics package, but version 1.7.3 incorporates most of the commonly
- requested features for an 8-bit 2D package. Support for truecolor
- images, JPEG and truecolor PNG is planned for version 2.0.
-
-AUTHOR
- gd was written by Thomas Boutell and is currently distributed by
- boutell.com, Inc.
-
-WWW: http://www.boutell.com/gd/
diff --git a/graphics/gd2/pkg-plist b/graphics/gd2/pkg-plist
deleted file mode 100644
index b72a1755a32b..000000000000
--- a/graphics/gd2/pkg-plist
+++ /dev/null
@@ -1,20 +0,0 @@
-bin/bdftogd
-bin/pngtogd
-bin/pngtogd2
-bin/gdtopng
-bin/gd2topng
-bin/gd2copypal
-bin/gdparttopng
-bin/webpng
-include/gd/gd.h
-include/gd/gd_io.h
-include/gd/gdcache.h
-include/gd/gdfontg.h
-include/gd/gdfontl.h
-include/gd/gdfontmb.h
-include/gd/gdfonts.h
-include/gd/gdfontt.h
-lib/libgd.a
-lib/libgd.so
-lib/libgd.so.1
-@dirrm include/gd