aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal/files/patch-swig-python-GNUmakefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gdal/files/patch-swig-python-GNUmakefile')
-rw-r--r--graphics/gdal/files/patch-swig-python-GNUmakefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/gdal/files/patch-swig-python-GNUmakefile b/graphics/gdal/files/patch-swig-python-GNUmakefile
index 04988668b7ba..a8a14b4b9528 100644
--- a/graphics/gdal/files/patch-swig-python-GNUmakefile
+++ b/graphics/gdal/files/patch-swig-python-GNUmakefile
@@ -1,20 +1,20 @@
---- swig/python/GNUmakefile.orig 2007-11-26 16:02:20.000000000 +0800
-+++ swig/python/GNUmakefile 2008-02-13 14:27:20.000000000 +0800
-@@ -43,7 +43,7 @@
+--- swig/python/GNUmakefile.orig 2008-05-31 11:41:25.000000000 +0400
++++ swig/python/GNUmakefile 2009-03-03 00:05:31.000000000 +0300
+@@ -47,7 +47,7 @@
generate: ${WRAPPERS}
build:
-- python setup.py build
-+ CXX="" python setup.py bdist_egg
+- $(PYTHON) setup.py build
++ CXX="" $(PYTHON) setup.py bdist_egg
egg:
- python setup.py bdist_egg
-@@ -51,7 +51,7 @@
+ $(PYTHON) setup.py bdist_egg
+@@ -55,7 +55,7 @@
install:
ifeq ($(PY_HAVE_SETUPTOOLS),1)
-- python setup.py install
+- $(PYTHON) setup.py install
+ env %%MAKE_ENV%% python setup.py easy_install -O 1 -N -S %%PYTHON_SITELIBDIR%% -d %%PYEASYINSTALL_SITELIBDIR%% -s %%PYEASYINSTALL_BINDIR%% %%WRKSRC%%/swig/python/dist/%%PYEASYINSTALL_EGG%%
else
- python setup.py install --prefix=$(DESTDIR)$(prefix)
+ $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
endif