aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdchart/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gdchart/files/Makefile')
-rw-r--r--graphics/gdchart/files/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/gdchart/files/Makefile b/graphics/gdchart/files/Makefile
new file mode 100644
index 000000000000..d95829174806
--- /dev/null
+++ b/graphics/gdchart/files/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+LIB= gdc
+CFLAGS+= -I${LOCALBASE}/include
+LDADD= -L${LOCALBASE}/lib \
+ -lgd \
+ -ljpeg \
+ -lfreetype
+SRCS= array_alloc.c \
+ gdc.c \
+ gdc_pie.c \
+ gdchart.c \
+ gifencode.c \
+ price_conv.c
+INCS= gdc.h \
+ gdchart.h \
+ gdcpie.h \
+ gifencode.h
+NOMAN= YES
+PREFIX?= /usr/local
+LOCALBASE?= /usr/local
+LIBDIR= ${PREFIX}/lib
+INCSDIR= ${PREFIX}/include
+INCDIR= ${INCSDIR} # for pre-bsd.incs.mk API
+
+.include <bsd.lib.mk>