aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdk-pixbuf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gdk-pixbuf/Makefile')
-rw-r--r--graphics/gdk-pixbuf/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/graphics/gdk-pixbuf/Makefile b/graphics/gdk-pixbuf/Makefile
index 90bfdbd3b736..9b8da6463eba 100644
--- a/graphics/gdk-pixbuf/Makefile
+++ b/graphics/gdk-pixbuf/Makefile
@@ -13,18 +13,17 @@ MASTER_SITE_SUBDIR= unstable/sources/gdk-pixbuf
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_GNOMELIBS= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+pre-patch:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
+ s|\$$\(datadir\)/aclocal|\$$\(prefix\)/share/aclocal|g'
+
.include <bsd.port.mk>