aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-app/files
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp-app/files')
-rw-r--r--graphics/gimp-app/files/gimp.setfont298
-rw-r--r--graphics/gimp-app/files/patch-aa21
-rw-r--r--graphics/gimp-app/files/patch-ab13
-rw-r--r--graphics/gimp-app/files/patch-ae10
-rw-r--r--graphics/gimp-app/files/patch-af16
-rw-r--r--graphics/gimp-app/files/patch-ah35
-rw-r--r--graphics/gimp-app/files/patch-ak17
-rw-r--r--graphics/gimp-app/files/patch-am19
8 files changed, 0 insertions, 429 deletions
diff --git a/graphics/gimp-app/files/gimp.setfont b/graphics/gimp-app/files/gimp.setfont
deleted file mode 100644
index e4e370d94993..000000000000
--- a/graphics/gimp-app/files/gimp.setfont
+++ /dev/null
@@ -1,298 +0,0 @@
-#!/usr/bin/perl
-
-# Font setting Perl script for GIMP
-#
-# by MANTANI Nobutaka <nobutaka@nobutaka.com>
-
-$progname = "gimp.setfont";
-$version = "Version 0.3 Sep 22 1999";
-
-# Show usage
-sub usage() {
- print <<EOF;
-Usage: gimp.setfont <language>
-
-----------------------------------------------------------------
-[language] [fontset]
- czech -*-fixed-(iso8859-2)
- danish -*-helvetica-(iso8859-1)
- dutch -*-helvetica-(iso8859-1)
- english -*-helvetica-(iso8859-1)
- finnish -*-helvetica-(iso8859-1)
- french -*-helvetica-(iso8859-1)
- german -*-helvetica-(iso8859-1)
- hungarian -*-fixed-(iso8859-2)
- italian -*-helvetica-(iso8859-1)
- japanese -*-fixed-(iso8859-1,jisx0201,jisx0208)
- korean -*-fixed-(iso8859-1),-daewoo-gothic-(ksc5601)
- polish -*-fixed-(iso8859-2)
- russian -*-helvetica-(koi8-r)
- swedish -*-helvetica-(iso8859-1)
- norwegian -*-helvetica-(iso8859-1)
-----------------------------------------------------------------
-
-If you need iso8859-2 fonts, please install etlfonts
-(ports/x11-fonts/etlfonts).
-
-EOF
-}
-
-# Write gtkrc of user's .gimp-1.1 directory
-sub write_gtkrc($) {
- $fontset = shift;
- $path = "$ENV{'HOME'}/.gimp-1.1";
-
- if (-d $path) {
- if (-e "$path/gtkrc") {
- chmod(0644, "$path/gtkrc");
- print "Renaming $path/gtkrc to ${path}/gtkrc.old...\n";
- rename("${path}/gtkrc", "${path}/gtkrc.old");
- }
-
- print "Writing $path/gtkrc...\n";
- open(FILE, ">$path/gtkrc");
- print FILE <<EOF;
-\# style <name> [= <name>]
-\# {
-\# <option>
-\# }
-\#
-\# widget <widget_set> style <style_name>
-\# widget_class <widget_class_set> style <style_name>
-
-style "default"
-{
- fontset = "$fontset"
-}
-
-widget_class "*" style "default"
-EOF
- close(FILE);
- print "Done.\n\n";
- } else {
- print <<EOF;
-Directory $path is not found.
-Please execute "gimp" and install files into $path
-directory first.
-
-EOF
- exit;
- }
-}
-
-$lang = $ARGV[0];
-$fontset = "";
-
-print <<EOF;
-
-$progname - Font setting utility for GIMP ($version)
-
-EOF
-
-if (@ARGV != 1) {
- usage();
- exit;
-}
-
-if ($lang eq "czech") {
- $fontset = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
-
- print "Setting for Czech language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "cs_CZ.ISO8859-2" and execute "gimp".
-And please make symbolic link from lt_LN.ISO_8859-2 to cs_CZ.ISO8859-2 in
-/usr/share/locale.
-
-EOF
- exit;
-}
-
-if ($lang eq "danish") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-
- print "Setting for Danish language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "da_DK.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "dutch") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-
- print "Setting for Dutch language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "nl_NL.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "english") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for English language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "C" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "finnish") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for Finnish language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "fi_FI.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "french") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for French language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "fr_FR.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "german") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for German language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "de_DE.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "hungarian") {
- $fontset = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
- print "Setting for Hungarian language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "hu_HU.ISO_8859-2" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "italian") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for Italian language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "it_IT.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "japanese") {
- $fontset = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-1,-*-fixed-medium-r-normal--14-*-*-*-*-*-jisx0201.1976-0,-*-fixed-medium-r-normal--14-*-*-*-*-*-jisx0208.1983-0";
- print "Setting for Japanese language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "ja_JP.EUC" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "korean") {
- $fontset = "-*-fixed-medium-r-normal--16-*-*-*-*-*-iso8859-1,-daewoo-gothic-medium-r-normal--16-*-*-*-*-*-ksc5601.1987-0";
- print "Setting for Korean language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "ko_KR.EUC" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "polish") {
- $fontset = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
- print "Setting for Polish language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "pl_PL.ISO_8859-2" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "russian") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-koi8-r";
- print "Setting for Russian language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "ru_SU.KOI8-R" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "swedish") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for Swedish language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "sv_SE.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-if ($lang eq "norwegian") {
- $fontset = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
- print "Setting for Norwegian language...\n\n";
-
- write_gtkrc($fontset);
-
- print <<EOF;
-Please set "LANG" environment variable to "no_NO.ISO_8859-1" and execute "gimp".
-
-EOF
- exit;
-}
-
-usage();
-exit;
diff --git a/graphics/gimp-app/files/patch-aa b/graphics/gimp-app/files/patch-aa
deleted file mode 100644
index 16de4cd974ff..000000000000
--- a/graphics/gimp-app/files/patch-aa
+++ /dev/null
@@ -1,21 +0,0 @@
---- app/main.c.orig Wed Oct 6 13:55:38 1999
-+++ app/main.c Tue Oct 12 13:23:44 1999
-@@ -16,7 +16,7 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- */
- #include "config.h"
--
-+#include <floatingpoint.h>
- #include <locale.h>
- #include <stdio.h>
- #include <stdlib.h>
-@@ -117,6 +117,9 @@
-
- /* Initialize variables */
- prog_name = argv[0];
-+
-+ /* Ignore floating point exceptions */
-+ fpsetmask(0);
-
- /* Initialize i18n support */
-
diff --git a/graphics/gimp-app/files/patch-ab b/graphics/gimp-app/files/patch-ab
deleted file mode 100644
index 4a00a2ad60f9..000000000000
--- a/graphics/gimp-app/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
---- plug-ins/common/url.c Sun Nov 7 19:24:37 1999
-+++ plug-ins/common/url.c.new Sun Nov 7 19:26:39 1999
-@@ -151,8 +151,8 @@
- }
- else if (pid == 0)
- {
-- execlp ("wget", "wget", filename, "-O", tmpname, NULL);
-- g_message ("url: exec failed: wget: %s\n", g_strerror(errno));
-+ execlp ("fetch", "fetch", filename, "-p -o", tmpname, NULL);
-+ g_message ("url: exec failed: fetch: %s\n", g_strerror(errno));
- g_free (tmpname);
- _exit(127);
- }
diff --git a/graphics/gimp-app/files/patch-ae b/graphics/gimp-app/files/patch-ae
deleted file mode 100644
index a7416000f0e6..000000000000
--- a/graphics/gimp-app/files/patch-ae
+++ /dev/null
@@ -1,10 +0,0 @@
---- plug-ins/common/plugindetails.c.orig Sat Mar 27 07:53:38 1999
-+++ plug-ins/common/plugindetails.c Sat May 22 21:24:31 1999
-@@ -25,6 +25,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <time.h>
-+#include <sys/types.h>
- #include "gtk/gtk.h"
- #include "libgimp/gimp.h"
-
diff --git a/graphics/gimp-app/files/patch-af b/graphics/gimp-app/files/patch-af
deleted file mode 100644
index 87ce6b507805..000000000000
--- a/graphics/gimp-app/files/patch-af
+++ /dev/null
@@ -1,16 +0,0 @@
---- gimptool.in.orig Wed Aug 25 18:49:22 1999
-+++ gimptool.in Tue Oct 12 13:31:37 1999
-@@ -209,11 +209,11 @@
- | --uninstall-script | --uninstall-admin-script )
- case $1 in
- --*install-bin)
-- install_cmd="@INSTALL_PROGRAM@"
-+ install_cmd="@INSTALL_SCRIPT@"
- install_dir="$HOME/@gimpdir@/plug-ins"
- ;;
- --install-bin-strip)
-- install_cmd="@INSTALL_PROGRAM@ -s"
-+ install_cmd="@INSTALL_SCRIPT@ -s"
- install_dir="$HOME/@gimpdir@/plug-ins"
- ;;
- --*install-admin-bin)
diff --git a/graphics/gimp-app/files/patch-ah b/graphics/gimp-app/files/patch-ah
deleted file mode 100644
index 80d4d82eb59c..000000000000
--- a/graphics/gimp-app/files/patch-ah
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.orig Wed Oct 6 14:00:22 1999
-+++ configure Tue Oct 12 13:37:31 1999
-@@ -3471,7 +3471,11 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
-+ INTLDEPS='-lintl'
-+ INTLLIBS=$INTLDEPS
-+ LIBS=`echo $LIBS | sed -e 's/-lintl//'`
-+
- fi
- rm -f conftest*
- INSTOBJEXT=.mo
-@@ -7108,7 +7112,7 @@
- fi
-
- gimpdatadir=$datadir/gimp
--gimpplugindir=$libdir/$PACKAGE/$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
-+gimpplugindir=$libexecdir/$PACKAGE/$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
- localedir='${prefix}/${DATADIRNAME}/locale'
-
- brushdata=`ls -1 $srcdir/data/brushes | grep -v Makefile`
-@@ -8513,10 +8517,6 @@
- top_srcdir="$ac_dots$ac_given_srcdir" ;;
- esac
-
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
-
- echo creating "$ac_file"
- rm -f "$ac_file"
diff --git a/graphics/gimp-app/files/patch-ak b/graphics/gimp-app/files/patch-ak
deleted file mode 100644
index 0d660de2f208..000000000000
--- a/graphics/gimp-app/files/patch-ak
+++ /dev/null
@@ -1,17 +0,0 @@
---- libgimp/Makefile.in.orig Tue Mar 9 02:58:39 1999
-+++ libgimp/Makefile.in Tue May 18 09:42:40 1999
-@@ -188,11 +188,11 @@
- gimpinclude_HEADERS = color_selector.h gimp.h gimpchainbutton.h gimpenums.h gimpenv.h gimpfeatures.h gimpmatrix.h gimpmenu.h gimpmodule.h gimpsizeentry.h gimpui.h gimpunit.h gimpunitmenu.h gimpintl.h gserialize.h parasite.h parasiteF.h parasiteP.h
-
-
--libgimp_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-+libgimp_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
--libgimp_la_LIBADD = $(GLIB_LIBS) -lm
-+libgimp_la_LIBADD = $(GTK_LIBS) -lm
-
--libgimpui_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-+libgimpui_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- libgimpui_la_LIBADD = $(GTK_LIBS)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/graphics/gimp-app/files/patch-am b/graphics/gimp-app/files/patch-am
deleted file mode 100644
index 368e279354da..000000000000
--- a/graphics/gimp-app/files/patch-am
+++ /dev/null
@@ -1,19 +0,0 @@
---- libgimp/gimp.c.orig Tue Sep 29 22:35:20 1998
-+++ libgimp/gimp.c Tue Sep 29 22:36:00 1998
-@@ -19,6 +19,7 @@
- #include "config.h"
-
- #include <errno.h>
-+#include <floatingpoint.h>
- #include <signal.h>
- #include <stdarg.h>
- #include <stdio.h>
-@@ -95,6 +96,8 @@
- }
-
- progname = argv[0];
-+
-+ fpsetmask(0);
-
- signal (SIGHUP, gimp_signal);
- signal (SIGINT, gimp_signal);