aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-wavelet-decompose-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp-wavelet-decompose-plugin/Makefile')
-rw-r--r--graphics/gimp-wavelet-decompose-plugin/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/graphics/gimp-wavelet-decompose-plugin/Makefile b/graphics/gimp-wavelet-decompose-plugin/Makefile
index cd95b76d64ad..1ba582bfa433 100644
--- a/graphics/gimp-wavelet-decompose-plugin/Makefile
+++ b/graphics/gimp-wavelet-decompose-plugin/Makefile
@@ -21,19 +21,13 @@ OPTIONS_DEFINE= NLS
USES= gettext gmake
-PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
-PLUGIN_DIR?= libexec/gimp/2.2/plug-ins/
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
# l10n languages
LANGUAGES= de ru it pl
# installed files
-PLIST_FILES= %%PLUGIN_DIR%%/wavelet-decompose
-
-# installed dirs
-PLIST_DIRSTRY= libexec/gimp/2.2/plug-ins \
- libexec/gimp/2.2 \
- libexec/gimp
+PLIST_FILES= ${PLUGIN_DIR}/wavelet-decompose
.include <bsd.port.options.mk>
@@ -55,10 +49,6 @@ post-patch:
.if ${PORT_OPTIONS:MNLS}
.for language in ${LANGUAGES}
PLIST_FILES+= share/locale/${language}/LC_MESSAGES/gimp20-${PORTNAME}-plug-in.mo
-
-PLIST_DIRSTRY+= share/locale/${language}/LC_MESSAGES \
- share/locale/${language} \
- share/locale
.endfor
.endif