aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-wavelet-decompose-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp-wavelet-decompose-plugin')
-rw-r--r--graphics/gimp-wavelet-decompose-plugin/Makefile78
-rw-r--r--graphics/gimp-wavelet-decompose-plugin/distinfo2
-rw-r--r--graphics/gimp-wavelet-decompose-plugin/files/patch-src__Makefile8
-rw-r--r--graphics/gimp-wavelet-decompose-plugin/pkg-descr12
4 files changed, 100 insertions, 0 deletions
diff --git a/graphics/gimp-wavelet-decompose-plugin/Makefile b/graphics/gimp-wavelet-decompose-plugin/Makefile
new file mode 100644
index 000000000000..ed5af90daddf
--- /dev/null
+++ b/graphics/gimp-wavelet-decompose-plugin/Makefile
@@ -0,0 +1,78 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wavelet-decompose
+DISTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://registry.gimp.org/files/
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Gimp plugin to losslessly decompose images into wavelet scales layers
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+
+OPTIONS_DEFINE= NLS
+
+USES= gettext gmake
+
+PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins/
+
+# l10n languages
+LANGUAGES= de ru it pl
+
+# installed files
+PLIST_FILES= %%PLUGIN_DIR%%/wavelet-decompose
+
+# installed dirs
+PLIST_DIRSTRY= libexec/gimp/2.2/plug-ins \
+ libexec/gimp/2.2 \
+ libexec/gimp
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ ${WRKSRC}/src/Makefile
+#
+## l10n
+# disable l10n if appropriate
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -E \
+ -e 's|(^all:.*)po |\1|' \
+ ${WRKSRC}/Makefile
+.endif
+
+## l10n
+#
+.if ${PORT_OPTIONS:MNLS}
+.for language in ${LANGUAGES}
+PLIST_FILES+= share/locale/${language}/LC_MESSAGES/gimp20-${PORTNAME}-plug-in.mo
+
+PLIST_DIRSTRY+= share/locale/${language}/LC_MESSAGES \
+ share/locale/${language} \
+ share/locale
+.endfor
+.endif
+
+do-install:
+# plugin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/wavelet-decompose ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+#
+## l10n
+#
+.if ${PORT_OPTIONS:MNLS}
+.for language in ${LANGUAGES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${language}/LC_MESSAGES/
+ ${INSTALL_DATA} ${WRKSRC}/po/${language}.mo ${STAGEDIR}${PREFIX}/share/locale/${language}/LC_MESSAGES/gimp20-${PORTNAME}-plug-in.mo
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-wavelet-decompose-plugin/distinfo b/graphics/gimp-wavelet-decompose-plugin/distinfo
new file mode 100644
index 000000000000..211cae288587
--- /dev/null
+++ b/graphics/gimp-wavelet-decompose-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wavelet-decompose-0.1.2.tar.gz) = 7a3217958646468a9b3668d64ca635d6bcfba9ababcff4cce91e38861e50b681
+SIZE (wavelet-decompose-0.1.2.tar.gz) = 18075
diff --git a/graphics/gimp-wavelet-decompose-plugin/files/patch-src__Makefile b/graphics/gimp-wavelet-decompose-plugin/files/patch-src__Makefile
new file mode 100644
index 000000000000..1856b572e9e1
--- /dev/null
+++ b/graphics/gimp-wavelet-decompose-plugin/files/patch-src__Makefile
@@ -0,0 +1,8 @@
+--- src/Makefile.orig 2014-03-22 22:50:21.000000000 -0300
++++ src/Makefile 2014-03-22 22:50:36.000000000 -0300
+@@ -1,4 +1,4 @@
+-CFLAGS = -O3 -Wall $(shell gimptool-2.0 --cflags)
++CFLAGS = $(shell gimptool-2.0 --cflags)
+ LIBS = $(shell gimptool-2.0 --libs)
+ PLUGIN = wavelet-decompose
+ SOURCES = plugin.c wavelet.c interface.c decompose.c
diff --git a/graphics/gimp-wavelet-decompose-plugin/pkg-descr b/graphics/gimp-wavelet-decompose-plugin/pkg-descr
new file mode 100644
index 000000000000..2d81ad8e89b3
--- /dev/null
+++ b/graphics/gimp-wavelet-decompose-plugin/pkg-descr
@@ -0,0 +1,12 @@
+[ edited version of author's www site ]
+
+This plugin losslessly decomposes a layer of an image into layers
+of wavelet scales. This means that you can edit the image on different
+detail scales (frequencies). The trivial recomposition of the image
+can be done by GIMP's layer modes so you can see the results of
+your modifications instantly. Among the applications are retouching,
+noise reduction, and enhancing global contrast.
+
+The plugin can be found under "Filters > Generic > Wavelet decompose"
+
+WWW: http://registry.gimp.org/node/11742