aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp/Makefile')
-rw-r--r--graphics/gimp/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/gimp/Makefile b/graphics/gimp/Makefile
index 28220c445ecf..4f7125a3a9da 100644
--- a/graphics/gimp/Makefile
+++ b/graphics/gimp/Makefile
@@ -3,19 +3,19 @@
# Date created: Mon Nov 18 21:28:43 CST 1996
# Whom: erich@FreeBSD.org
#
-# $Id: Makefile,v 1.17 1998/01/05 17:56:39 erich Exp $
+# $Id: Makefile,v 1.18 1998/01/07 13:34:07 erich Exp $
#
MAJOR= 0
MINOR= 99
-MICRO= 17
+MICRO= 18
VERSION= ${MAJOR}.${MINOR}.${MICRO}
MM_VERSION= ${MAJOR}.${MINOR}
DISTNAME= gimp-${VERSION}
DISTFILES= ${DISTNAME}.tar.gz
-DISTFILES+= gimp-data-min-${MM_VERSION}a.tar.gz \
+DISTFILES+= gimp-data-min-${MM_VERSION}b.tar.gz \
gimp-data-extras-${MM_VERSION}a.tar.gz
CATEGORIES= graphics
@@ -31,12 +31,13 @@ LIB_DEPENDS+= tiff34\\.1\\.:${PORTSDIR}/graphics/tiff34
LIB_DEPENDS+= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
LIB_DEPENDS+= mpeg\\.1\\.2:${PORTSDIR}/graphics/mpeg-lib
LIB_DEPENDS+= tk80\\.1\\.:${PORTSDIR}/x11/tk80
+LIB_DEPENDS+= xdelta\\.0:${PORTSDIR}/misc/xdelta
USE_X11= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= LD=/usr/bin/ld \
- CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.0 \
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.0 \
-I${LOCALBASE}/include/tk8.0 -I${LOCALBASE}/include/tiff34" \
LIBS=-L${LOCALBASE}/lib INSTALL_SCRIPT='$${INSTALL} -m 755'
CONFIGURE_ARGS= --with-tcl=tcl80 --with-tk=tk80
@@ -45,7 +46,7 @@ DATASTUFF= brushes palettes gradients patterns
post-install:
mkdir -p ${PREFIX}/share/gimp/;
- cd ${WRKDIR}/gimp-data-min-${MM_VERSION}a; \
+ cd ${WRKDIR}/gimp-data-min-${MM_VERSION}b; \
tar -cf - --exclude '*Makefile*' ${DATASTUFF} |\
(cd ${PREFIX}/share/gimp/; tar -xvf -)
cd ${WRKDIR}/gimp-data-extras-${MM_VERSION}a; \