aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimpshop/files
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimpshop/files')
-rw-r--r--graphics/gimpshop/files/gimp.setfont154
-rw-r--r--graphics/gimpshop/files/patch-aa20
-rw-r--r--graphics/gimpshop/files/patch-ab13
-rw-r--r--graphics/gimpshop/files/patch-ae11
-rw-r--r--graphics/gimpshop/files/patch-af16
-rw-r--r--graphics/gimpshop/files/patch-ah35
-rw-r--r--graphics/gimpshop/files/patch-ak11
-rw-r--r--graphics/gimpshop/files/patch-am20
8 files changed, 0 insertions, 280 deletions
diff --git a/graphics/gimpshop/files/gimp.setfont b/graphics/gimpshop/files/gimp.setfont
deleted file mode 100644
index 487a91baf0e6..000000000000
--- a/graphics/gimpshop/files/gimp.setfont
+++ /dev/null
@@ -1,154 +0,0 @@
-#!/usr/bin/perl
-
-# Font setting Perl script for GIMP
-#
-# by MANTANI Nobutaka <nobutaka@nobutaka.com>
-
-$progname = "gimp.setfont";
-$version = "Version 0.4 Feb 07 2000";
-
-$fontset{'czech'} = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
-$fontset{'danish'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'dutch'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'english'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'finnish'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'french'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'german'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'hungarian'} = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
-$fontset{'italian'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'japanese'} = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-1,-*-fixed-medium-r-normal--14-*-*-*-*-*-jisx0201.1976-0,-*-fixed-medium-r-normal--14-*-*-*-*-*-jisx0208.1983-0";
-$fontset{'korean'} = "-*-fixed-medium-r-normal--16-*-*-*-*-*-iso8859-1,-daewoo-gothic-medium-r-normal--16-*-*-*-*-*-ksc5601.1987-0";
-$fontset{'norwegian'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'polish'} = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
-$fontset{'russian'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-koi8-r";
-$fontset{'slovak'} = "-*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-2";
-$fontset{'swedish'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-iso8859-1";
-$fontset{'ukrainian'} = "-*-helvetica-medium-r-normal--14-*-*-*-*-*-koi8-r";
-
-$locale{'czech'} = "cs_CZ.ISO8859-2";
-$locale{'danish'} = "da_DK.ISO_8859-1";
-$locale{'dutch'} = "nl_NL.ISO_8859-1";
-$locale{'english'} = "C";
-$locale{'finnish'} = "fi_FI.ISO_8859-1";
-$locale{'french'} = "fr_FR.ISO_8859-1";
-$locale{'german'} = "de_DE.ISO_8859-1";
-$locale{'hungarian'} = "hu_HU.ISO_8859-2";
-$locale{'italian'} = "it_IT.ISO_8859-1";
-$locale{'japanese'} = "ja_JP.EUC";
-$locale{'korean'} = "ko_KR.EUC";
-$locale{'norwegian'} = "no_NO.ISO_8859-1";
-$locale{'polish'} = "pl_PL.ISO_8859-2";
-$locale{'russian'} = "ru_SU.KOI8-R";
-$locale{'slovak'} = "sk_SK.ISO_8859-2";
-$locale{'swedish'} = "sv_SE.ISO_8859-1";
-$locale{'ukrainian'} = "uk_UA.KOI8-U";
-
-# Show usage
-sub usage() {
- print <<EOF;
-Usage: gimp.setfont <language>
-
-----------------------------------------------------------------
-[language] [fontset]
- czech -*-fixed-(iso8859-2)
- danish -*-helvetica-(iso8859-1)
- dutch -*-helvetica-(iso8859-1)
- english -*-helvetica-(iso8859-1)
- finnish -*-helvetica-(iso8859-1)
- french -*-helvetica-(iso8859-1)
- german -*-helvetica-(iso8859-1)
- hungarian -*-fixed-(iso8859-2)
- italian -*-helvetica-(iso8859-1)
- japanese -*-fixed-(iso8859-1,jisx0201,jisx0208)
- korean -*-fixed-(iso8859-1),-daewoo-gothic-(ksc5601)
- norwegian -*-helvetica-(iso8859-1)
- polish -*-fixed-(iso8859-2)
- russian -*-helvetica-(koi8-r)
- slovak -*-fixed-(iso8869-2)
- swedish -*-helvetica-(iso8859-1)
- ukrainian -*-helvetica-(koi8-r)
-----------------------------------------------------------------
-
-If you need iso8859-2 fonts, please install etlfonts
-(x11-fonts/etlfonts).
-
-EOF
-}
-
-# Write gtkrc of user's .gimp-1.1 directory
-sub write_gtkrc($) {
- my $fontset = shift;
- my $path = "$ENV{'HOME'}/.gimp-1.1";
-
- if (-d $path) {
- if (-e "$path/gtkrc") {
- chmod(0644, "$path/gtkrc");
- print "Renaming $path/gtkrc to $path/gtkrc.old...\n";
- rename("$path/gtkrc", "$path/gtkrc.old");
- }
-
- print "Writing $path/gtkrc...\n";
- open(FILE, ">$path/gtkrc");
- print FILE <<EOF;
-\# style <name> [= <name>]
-\# {
-\# <option>
-\# }
-\#
-\# widget <widget_set> style <style_name>
-\# widget_class <widget_class_set> style <style_name>
-
-style "default"
-{
- fontset = "$fontset"
-}
-
-widget_class "*" style "default"
-EOF
- close(FILE);
- print "Done.\n\n";
- } else {
- print <<EOF;
-Directory $path is not found.
-Please execute "gimp" and install files into $path
-directory first.
-
-EOF
- exit;
- }
-}
-
-sub main() {
- my $lang = $ARGV[0];
- my $tmp = ucfirst($lang);
-
- print <<EOF;
-
-$progname - Font setting utility for GIMP ($version)
-
-EOF
-
- if (@ARGV != 1) {
- usage();
- exit;
- }
-
- print "Setting for $tmp language...\n\n";
-
- print qq(Please set "LANG" environment variable to "$locale{$lang}" and execute "gimp".\n\n);
-
- if ($lang eq "slovak") {
- print <<EOF;
-And please make symbolic link from lt_LN.ISO_8859-2 to sk_SK.ISO_8859-2 in
-/usr/share/locale.
-
-EOF
- }
-
- write_gtkrc($fontset{$lang});
-
- exit;
-}
-
-
-main();
diff --git a/graphics/gimpshop/files/patch-aa b/graphics/gimpshop/files/patch-aa
deleted file mode 100644
index 33a7ddbd83b8..000000000000
--- a/graphics/gimpshop/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- app/main.c.orig Thu Feb 10 14:41:02 2000
-+++ app/main.c Sat Feb 19 13:51:36 2000
-@@ -22,6 +22,7 @@
- #include <signal.h>
- #include <string.h>
- #include <sys/types.h>
-+#include <floatingpoint.h>
-
- #ifdef HAVE_SYS_WAIT_H
- #include <sys/wait.h>
-@@ -129,6 +130,9 @@
- /* Initialize variables */
-
- prog_name = argv[0];
-+
-+ /* Ignore floating point exceptions */
-+ fpsetmask(0);
-
- /* Initialize i18n support */
- INIT_LOCALE ("gimp");
diff --git a/graphics/gimpshop/files/patch-ab b/graphics/gimpshop/files/patch-ab
deleted file mode 100644
index 2e37f7c44cff..000000000000
--- a/graphics/gimpshop/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
---- plug-ins/common/url.c.orig Tue Feb 1 16:09:01 2000
-+++ plug-ins/common/url.c Sat Feb 19 13:51:36 2000
-@@ -158,8 +158,8 @@
- }
- else if (pid == 0)
- {
-- execlp ("wget", "wget", filename, "-O", tmpname, NULL);
-- g_message ("url: exec failed: wget: %s\n", g_strerror(errno));
-+ execlp ("fetch", "fetch", filename, "-p -o", tmpname, NULL);
-+ g_message ("url: exec failed: fetch: %s\n", g_strerror(errno));
- g_free (tmpname);
- _exit(127);
- }
diff --git a/graphics/gimpshop/files/patch-ae b/graphics/gimpshop/files/patch-ae
deleted file mode 100644
index a9cd977ed014..000000000000
--- a/graphics/gimpshop/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- plug-ins/common/plugindetails.c.orig Fri Jan 14 17:26:07 2000
-+++ plug-ins/common/plugindetails.c Fri Jan 14 17:26:21 2000
-@@ -27,7 +27,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <time.h>
--
-+#include <sys/types.h>
- #include <gtk/gtk.h>
-
- #include "libgimp/gimp.h"
diff --git a/graphics/gimpshop/files/patch-af b/graphics/gimpshop/files/patch-af
deleted file mode 100644
index 87ce6b507805..000000000000
--- a/graphics/gimpshop/files/patch-af
+++ /dev/null
@@ -1,16 +0,0 @@
---- gimptool.in.orig Wed Aug 25 18:49:22 1999
-+++ gimptool.in Tue Oct 12 13:31:37 1999
-@@ -209,11 +209,11 @@
- | --uninstall-script | --uninstall-admin-script )
- case $1 in
- --*install-bin)
-- install_cmd="@INSTALL_PROGRAM@"
-+ install_cmd="@INSTALL_SCRIPT@"
- install_dir="$HOME/@gimpdir@/plug-ins"
- ;;
- --install-bin-strip)
-- install_cmd="@INSTALL_PROGRAM@ -s"
-+ install_cmd="@INSTALL_SCRIPT@ -s"
- install_dir="$HOME/@gimpdir@/plug-ins"
- ;;
- --*install-admin-bin)
diff --git a/graphics/gimpshop/files/patch-ah b/graphics/gimpshop/files/patch-ah
deleted file mode 100644
index 95af0d629b7f..000000000000
--- a/graphics/gimpshop/files/patch-ah
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.orig Fri Feb 11 10:32:12 2000
-+++ configure Sat Feb 19 13:51:36 2000
-@@ -3480,7 +3480,11 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
-+ INTLDEPS='-lintl'
-+ INTLLIBS=$INTLDEPS
-+ LIBS=`echo $LIBS | sed -e 's/-lintl//'`
-+
- fi
- rm -f conftest*
- INSTOBJEXT=.mo
-@@ -7017,7 +7021,7 @@
- fi
-
- gimpdatadir=$datadir/gimp
--gimpplugindir=$libdir/$PACKAGE/$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
-+gimpplugindir=$libexecdir/$PACKAGE/$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
- localedir='${prefix}/${DATADIRNAME}/locale'
-
- brushdata=`ls -1 $srcdir/data/brushes | grep -v Makefile`
-@@ -8561,10 +8565,6 @@
- top_srcdir="$ac_dots$ac_given_srcdir" ;;
- esac
-
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
-
- echo creating "$ac_file"
- rm -f "$ac_file"
diff --git a/graphics/gimpshop/files/patch-ak b/graphics/gimpshop/files/patch-ak
deleted file mode 100644
index 90837d0254f2..000000000000
--- a/graphics/gimpshop/files/patch-ak
+++ /dev/null
@@ -1,11 +0,0 @@
---- libgimp/Makefile.in.orig Fri Feb 11 10:42:12 2000
-+++ libgimp/Makefile.in Sat Feb 19 15:18:59 2000
-@@ -211,7 +211,7 @@
-
- libgimp_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-
--libgimp_la_LIBADD = $(GLIB_LIBS) -lm
-+libgimp_la_LIBADD = $(GTK_LIBS) -lm
-
- libgimpui_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-
diff --git a/graphics/gimpshop/files/patch-am b/graphics/gimpshop/files/patch-am
deleted file mode 100644
index 530b1aaa081e..000000000000
--- a/graphics/gimpshop/files/patch-am
+++ /dev/null
@@ -1,20 +0,0 @@
---- libgimp/gimp.c.orig Mon Dec 6 14:44:39 1999
-+++ libgimp/gimp.c Sat Feb 19 13:51:36 2000
-@@ -26,6 +26,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/types.h>
-+#include <floatingpoint.h>
- #ifdef HAVE_SYS_TIME_H
- #include <sys/time.h>
- #endif
-@@ -186,6 +187,9 @@
- }
-
- progname = argv[0];
-+
-+ /* Ignore floating point exceptions */
-+ fpsetmask(0);
-
- #ifndef G_OS_WIN32
- /* No use catching these on Win32, the user won't get any meaningful