aboutsummaryrefslogtreecommitdiff
path: root/graphics/giram/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/giram/Makefile')
-rw-r--r--graphics/giram/Makefile26
1 files changed, 7 insertions, 19 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 5f7063a57b70..acc951725e4e 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -7,40 +7,28 @@
PORTNAME= giram
PORTVERSION= 0.3.5
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= graphics
-MASTER_SITES= http://freebsd.nsu.ru/distfiles/ \
- #http://www.giram.org/downloads/
+MASTER_SITES= http://freebsd.nsu.ru/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= A POV-Ray oriented modeller
LIB_DEPENDS= 3ds-1.3:${PORTSDIR}/graphics/lib3ds
+BUILD_DEPENDS= povray:${PORTSDIR}/graphics/povray-meta
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GETTEXT= yes
USE_PERL5_BUILD=yes
USE_GNOME= gtk20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
INTLTOOL_PERL="${PERL}"
CONFIGURE_ARGS= --datadir="${PREFIX}/lib" \
--with-tutorial-path="${DOCSDIR}" \
--with-lib3ds-prefix="${LOCALBASE}"
-
-OPTIONS= POVRAY31 "Build against POV-Ray 3.1" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_POVRAY31)
-BUILD_DEPENDS+= povray:${PORTSDIR}/graphics/povray31
-RUN_DEPENDS+= povray:${PORTSDIR}/graphics/povray31
-.else
-BUILD_DEPENDS+= povray:${PORTSDIR}/graphics/povray
-RUN_DEPENDS+= povray:${PORTSDIR}/graphics/povray
-.endif
+CPPFLAGS= -I${LOCALBASE}/include
MAN1= giram.1
@@ -55,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/samples/*.pov ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>