aboutsummaryrefslogtreecommitdiff
path: root/graphics/giram/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/giram/Makefile')
-rw-r--r--graphics/giram/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 64ddeb302b50..fcfc3ddf2c0d 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -19,7 +19,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_MESA= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gl=${X11BASE}
@@ -28,8 +29,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mlibcapplet}!=""
+USE_GNOME+= libcapplet
+PKGNAMESUFFIX= -gnome
.else
CONFIGURE_ARGS+=--disable-gnome
.endif