aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index b05780cde348..df340c259227 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -13,15 +13,17 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
+USE_NEWGCC= yes
+USE_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG} \
- CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+=--datadir=${PREFIX}/share
-USE_NEWGCC= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'
.include <bsd.port.mk>