aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnomecanvas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gnomecanvas/Makefile')
-rw-r--r--graphics/gnomecanvas/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/gnomecanvas/Makefile b/graphics/gnomecanvas/Makefile
new file mode 100644
index 000000000000..ecf501723d1d
--- /dev/null
+++ b/graphics/gnomecanvas/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnomecanvas
+# Date created: 18 May 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomecanvas
+CATEGORIES= graphics gnome
+
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+MASTERDIR= ${.CURDIR}/../gdk-pixbuf
+
+COMMENT= ${.CURDIR}/pkg-comment
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOMELIBS= yes
+
+BUILD_CANVAS= yes
+
+NAME= gnomecanvaspixbuf
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
+ cd ${WRKSRC}/gdk-pixbuf/.libs && \
+ ${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
+ ${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
+ ${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
+ ${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
+ ${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
+
+.include "${MASTERDIR}/Makefile"