aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnomecanvas
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gnomecanvas')
-rw-r--r--graphics/gnomecanvas/Makefile34
-rw-r--r--graphics/gnomecanvas/pkg-comment1
-rw-r--r--graphics/gnomecanvas/pkg-descr6
-rw-r--r--graphics/gnomecanvas/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/graphics/gnomecanvas/Makefile b/graphics/gnomecanvas/Makefile
new file mode 100644
index 000000000000..ecf501723d1d
--- /dev/null
+++ b/graphics/gnomecanvas/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnomecanvas
+# Date created: 18 May 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomecanvas
+CATEGORIES= graphics gnome
+
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+MASTERDIR= ${.CURDIR}/../gdk-pixbuf
+
+COMMENT= ${.CURDIR}/pkg-comment
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOMELIBS= yes
+
+BUILD_CANVAS= yes
+
+NAME= gnomecanvaspixbuf
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
+ cd ${WRKSRC}/gdk-pixbuf/.libs && \
+ ${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
+ ${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
+ ${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
+ ${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
+ ${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gnomecanvas/pkg-comment b/graphics/gnomecanvas/pkg-comment
new file mode 100644
index 000000000000..e5a8b45b1fea
--- /dev/null
+++ b/graphics/gnomecanvas/pkg-comment
@@ -0,0 +1 @@
+A graphic library for GNOME
diff --git a/graphics/gnomecanvas/pkg-descr b/graphics/gnomecanvas/pkg-descr
new file mode 100644
index 000000000000..8900db783bf3
--- /dev/null
+++ b/graphics/gnomecanvas/pkg-descr
@@ -0,0 +1,6 @@
+The GNOMECanvas library provides a number of features:
+
+ - Image loading facilities.
+ - Rendering of a GdkPixBuf into various formats:
+ drawables (windows, pixmaps), GdkRGB buffers.
+ - A cache interface
diff --git a/graphics/gnomecanvas/pkg-plist b/graphics/gnomecanvas/pkg-plist
new file mode 100644
index 000000000000..12399271f737
--- /dev/null
+++ b/graphics/gnomecanvas/pkg-plist
@@ -0,0 +1,5 @@
+etc/gnomecanvaspixbufConf.sh
+include/gdk-pixbuf/gnome-canvas-pixbuf.h
+lib/libgnomecanvaspixbuf.a
+lib/libgnomecanvaspixbuf.so
+lib/libgnomecanvaspixbuf.so.1