aboutsummaryrefslogtreecommitdiff
path: root/graphics/gpaint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gpaint/Makefile')
-rw-r--r--graphics/gpaint/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/gpaint/Makefile b/graphics/gpaint/Makefile
index a6f0a1852224..6fa991d76c08 100644
--- a/graphics/gpaint/Makefile
+++ b/graphics/gpaint/Makefile
@@ -14,16 +14,14 @@ MAINTAINER= sobomax@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gdkpixbuf gnomeprint
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>