aboutsummaryrefslogtreecommitdiff
path: root/graphics/gphoto2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gphoto2/Makefile')
-rw-r--r--graphics/gphoto2/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 37e18c6e20ef..96a15741fb6a 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -2,20 +2,21 @@
# $FreeBSD$
PORTNAME= gphoto2
-PORTVERSION= 2.5.14
+PORTVERSION= 2.5.15
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
MAINTAINER= woodsb02@FreeBSD.org
COMMENT= Command-line frontend to libgphoto2
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexif.so:graphics/libexif \
libgphoto2.so:graphics/libgphoto2 \
libpopt.so:devel/popt
-USES= gmake jpeg pkgconfig tar:bzip2
+USES= gmake jpeg localbase pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= POPT_CFLAGS="$$(pkg-config --cflags popt)" \
POPT_LIBS="$$(pkg-config --libs popt)"
@@ -30,8 +31,6 @@ AALIB_LIB_DEPENDS= libaa.so:graphics/aalib
AALIB_CONFIGURE_WITH= aalib
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
READLINE_USES= readline
READLINE_CONFIGURE_WITH= readline
THREADS_CONFIGURE_ENV_OFF= ac_cv_lib_pthread_pthread_exit=no