aboutsummaryrefslogtreecommitdiff
path: root/graphics/gphoto2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gphoto2/Makefile')
-rw-r--r--graphics/gphoto2/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index af5dfa9fd8d6..840d987affc7 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gphoto2
-PORTVERSION= 2.5.8
+PORTVERSION= 2.5.9
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
@@ -17,12 +17,11 @@ LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt \
USES= gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= POPT_CFLAGS="$$(pkg-config --cflags popt)" \
- POPT_LIBS="$$(pkg-config --libs popt)" \
- ac_cv_lib_pthread_pthread_exit=no
+ POPT_LIBS="$$(pkg-config --libs popt)"
CONFIGURE_ARGS= --without-cdk
-OPTIONS_DEFINE= AALIB DOCS NLS READLINE
-OPTIONS_DEFAULT= AALIB READLINE
+OPTIONS_DEFINE= AALIB DOCS NLS READLINE THREADS
+OPTIONS_DEFAULT= AALIB READLINE THREADS
OPTIONS_SUB= yes
AALIB_DESC= Text mode capture preview support
@@ -31,11 +30,12 @@ AALIB_CONFIGURE_WITH= aalib
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib -lintl
+NLS_LDFLAGS= -L${LOCALBASE}/lib
READLINE_USES= readline
-READLINE_CONFIGURE_WITH=readline
+READLINE_CONFIGURE_WITH= readline
+THREADS_CONFIGURE_ENV_OFF= ac_cv_lib_pthread_pthread_exit=no
-post-install:
+post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>