aboutsummaryrefslogtreecommitdiff
path: root/graphics/gqview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gqview/Makefile')
-rw-r--r--graphics/gqview/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index 7c7275cf5f97..b13152b4e21a 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -13,16 +13,26 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= nakai@FreeBSD.org
-LIB_DEPENDS= gdk_imlib.5:${PORTSDIR}/graphics/imlib
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
+USE_IMLIB= yes
+WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --without-gnome --disable-imlibtest --disable-gtktest
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+.else
+CONFIGURE_ENV+= GNOME_CONFIG=no
+.endif
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|GNOME_DATADIR\)/gnome/|GNOME_DATADIR\)/|g'
post-install:
.if !defined(NOPORTDOCS)
@@ -30,4 +40,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gqview
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>