aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/graphviz/Makefile')
-rw-r--r--graphics/graphviz/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 8a73197ce017..49008b66b4bf 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= graphviz
-PORTVERSION= 1.9
+PORTVERSION= 1.10
CATEGORIES= graphics tk84
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
@@ -31,13 +31,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4 -I
AUTOCONF=${LOCALBASE}/bin/autoconf213 \
AUTOMAKE=${LOCALBASE}/bin/automake14 \
ACLOCAL=${LOCALBASE}/bin/aclocal14
+CONFIGURE_ARGS= --program-transform-name="s/x/x/"
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/lib/graphviz
MAKE_ENV= EXPR_COMPAT=yes
MAN1= acyclic.1 ccomps.1 colorize.1 dot.1 dot2gxl.1 dotty.1 gc.1 \
- gpr.1 gxl2dot.1 lefty.1 neato.1 nop.1 prune.1 sccmap.1 \
- tred.1 twopi.1 unflatten.1
+ gpr.1 gxl2dot.1 gvpack.1 lefty.1 neato.1 nop.1 prune.1 \
+ sccmap.1 tred.1 twopi.1 unflatten.1
MAN3= agraph.3 cdt.3 expr.3 graph.3 pack.3 pathplan.3
MANN= gdtclft.n tcldgl.n tcldgr.n tcldot.n tkspline.n
@@ -47,8 +48,8 @@ PORTDOCS= dotguide.pdf dottyguide.pdf gd.html leftyguide.pdf \
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/include/iconv.h) || defined(WITH_ICONV)
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
-CONFIGURE_ARGS= --with-iconvlibdir=${LOCALBASE}/lib
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+CONFIGURE_ARGS+= --with-iconvlibdir=${LOCALBASE}/lib
.endif
post-install: