aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/graphviz/Makefile')
-rw-r--r--graphics/graphviz/Makefile33
1 files changed, 16 insertions, 17 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 9abe3791ea4f..4e3bf91fc649 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= graphviz
-PORTVERSION= 1.10
-PORTREVISION= 2
+PORTVERSION= 1.12
CATEGORIES= graphics tk84
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
@@ -17,33 +16,33 @@ COMMENT= Graph Visualization Software from AT&T and Bell Labs
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2 \
- tk84.1:${PORTSDIR}/x11-toolkits/tk84
+ tk84.1:${PORTSDIR}/x11-toolkits/tk84 \
+ expat.5:${PORTSDIR}/textproc/expat2
+USE_BISON= yes
+USE_GMAKE= yes
USE_ICONV= yes
USE_XPM= yes
-USE_GMAKE= yes
-USE_AUTOMAKE_VER= 14
-AUTOMAKE_ARGS= --add-missing
-USE_LIBTOOL_VER=13
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4" \
LDFLAGS="-L${LOCALBASE}/lib" \
TCLCONFIG=${LOCALBASE}/lib/tcl8.4/tclConfig.sh \
TKCONFIG=${LOCALBASE}/lib/tk8.4/tkConfig.sh \
- AUTOHEADER=${LOCALBASE}/bin/autoheader213 \
- AUTOCONF=${LOCALBASE}/bin/autoconf213 \
- AUTOMAKE=${LOCALBASE}/bin/automake14 \
- ACLOCAL=${LOCALBASE}/bin/aclocal14
+ MISSING=${TRUE}
CONFIGURE_ARGS= --program-transform-name="s/x/x/" \
- --with-iconvlibdir=${LOCALBASE}/lib
+ --with-iconvlibdir=${LOCALBASE}/lib \
+ --with-tclsh=${LOCALBASE}/tcl8.4 \
+ --with-wish=${LOCALBASE}/wish8.4
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/lib/graphviz
-MAKE_ENV= EXPR_COMPAT=yes
+MAKE_ENV= EXPR_COMPAT=yes MISSING=${TRUE}
-MAN1= acyclic.1 ccomps.1 colorize.1 dot.1 dot2gxl.1 dotty.1 gc.1 \
- gpr.1 gxl2dot.1 gvpack.1 lefty.1 neato.1 nop.1 prune.1 \
- sccmap.1 tred.1 twopi.1 unflatten.1
+MAN1= acyclic.1 bcomps.1 ccomps.1 circo.1 dijkstra.1 dot.1 \
+ dot2gxl.1 dotneato-config.1 dotty.1 fdp.1 gc.1 \
+ gxl2dot.1 gvcolor.1 gvpack.1 gvpr.1 lefty.1 lneato.1 \
+ neato.1 nop.1 prune.1 sccmap.1 tred.1 twopi.1 unflatten.1
MAN3= agraph.3 cdt.3 expr.3 graph.3 pack.3 pathplan.3
-MANN= gdtclft.n tcldgl.n tcldgr.n tcldot.n tkspline.n
+MANN= gdtclft.n tcldot.n tkspline.n
MYPORTDOCS= dotguide.pdf dottyguide.pdf gd.html leftyguide.pdf \
neatoguide.pdf tcldot.html Dot.ref FAQ.html