aboutsummaryrefslogtreecommitdiff
path: root/graphics/grx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/grx/Makefile')
-rw-r--r--graphics/grx/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/grx/Makefile b/graphics/grx/Makefile
index 158287a15769..c35f73909037 100644
--- a/graphics/grx/Makefile
+++ b/graphics/grx/Makefile
@@ -90,6 +90,10 @@ CONFIGURE_ARGS+=--disable-zlib
CONFIGURE_ARGS+=--enable-x86_64
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
post-patch:
@${GREP} -ERl '<(malloc|alloca)\.h>' ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -Ee 's|<(malloc\|alloca)\.h>|<stdlib.h>|'