aboutsummaryrefslogtreecommitdiff
path: root/graphics/gsculpt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gsculpt/Makefile')
-rw-r--r--graphics/gsculpt/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 5e4dbe447164..02a12e1445f4 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -18,6 +18,9 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}gtkglext>0:x11-toolkits/py-gtkglext
+BROKEN_powerpc= fails to compile
+BROKEN_sparc64= fails to compile
+
WRKSRC= ${WRKDIR}/${DISTNAME:S,-src,,}
USES= pkgconfig python:2 scons
@@ -34,11 +37,7 @@ DESKTOP_ENTRIES="gSculpt" "" \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= does not compile on ia64, powerpc, or sparc64
-.endif
-
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
CFLAGS+= -DGSCULPT_FPU_X86
.endif