aboutsummaryrefslogtreecommitdiff
path: root/graphics/gsnapshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gsnapshot/Makefile')
-rw-r--r--graphics/gsnapshot/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/gsnapshot/Makefile b/graphics/gsnapshot/Makefile
new file mode 100644
index 000000000000..b439033cc341
--- /dev/null
+++ b/graphics/gsnapshot/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gsnapshot
+# Date created: 23 July 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsnapshot
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A gtk+ based screen capture
+
+USE_AUTOTOOLS= automake:15:env libtool:15
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
+DESKTOP_ENTRIES= "gsnapshot" \
+ "A gtk+ based screen capture" \
+ "" \
+ "gsnapshot" \
+ "Application;Graphics;" \
+ "false"
+
+pre-configure:
+ @${LN} -sf ${AUTOMAKE_DIR}/install-sh ${WRKSRC}
+ @${LN} -sf ${AUTOMAKE_DIR}/depcomp ${WRKSRC}
+ @${LN} -sf ${AUTOMAKE_DIR}/missing ${WRKSRC}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>