aboutsummaryrefslogtreecommitdiff
path: root/graphics/gts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gts/Makefile')
-rw-r--r--graphics/gts/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index cbfb342bc13a..a813739fbf0e 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -3,34 +3,31 @@
PORTNAME= gts
PORTVERSION= 0.7.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= erik@bz.bzflag.bz
COMMENT= GNU Triangulated Surface Library
+LICENSE= LGPL20
+
USES= pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
OPTIONS_DEFINE= NETPBM
-NETPBM_DESC= Build with libnetpbm support
+OPTIONS_SUB= yes
+
+NETPBM_DESC= Build with libnetpbm support
+NETPBM_LIB_DEPENDS= libnetpbm.so:${PORTSDIR}/graphics/netpbm
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNETPBM}
-LIB_DEPENDS+= netpbm.1:${PORTSDIR}/graphics/netpbm
-PLIST_SUB= NETPBM=""
-.else
-PLIST_SUB= NETPBM="@comment "
-.endif
-
post-extract:
.if ! ${PORT_OPTIONS:MNETPBM}
@${REINPLACE_CMD} -e 's|netpbm="true"|netpbm="false"|' \