aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/hugin-devel/Makefile')
-rw-r--r--graphics/hugin-devel/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/graphics/hugin-devel/Makefile b/graphics/hugin-devel/Makefile
index c947f07fdb45..ed6f0d9df310 100644
--- a/graphics/hugin-devel/Makefile
+++ b/graphics/hugin-devel/Makefile
@@ -33,8 +33,10 @@ CONFLICTS_INSTALL= hugin-201[0-2]*
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
-OPTIONS= PANOMATIC "Install graphics/panomatic" on \
- AUTOPANOSIFTC "Install graphics/autopano-sift-c" on
+OPTIONS_DEFINE= PANOMATIC AUTOPANOSIFTC
+OPTIONS_DEFAULT= PANOMATIC AUTOPANOSIFTC
+PANOMATIC_DESC= Install graphics/panomatic
+AUTOPANOSIFTC_DESC= Install graphics/autopano-sift-c
USES= cmake gettext
@@ -93,14 +95,14 @@ post-configure:
${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/flags.make \
${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/link.txt
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PANOMATIC)
+.if ${PORT_OPTIONS:MPANOMATIC}
RUN_DEPENDS+= panomatic:${PORTSDIR}/graphics/panomatic
.endif
-.if defined(WITH_AUTOPANOSIFTC)
+.if ${PORT_OPTIONS:MAUTOPANOSIFTC}
RUN_DEPENDS+= autopano:${PORTSDIR}/graphics/autopano-sift-c
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>