aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/hugin/Makefile')
-rw-r--r--graphics/hugin/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 5319cb662263..ccef7953bc75 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -20,21 +20,20 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
fftw:${PORTSDIR}/math/fftw \
- wx_gtk2_xrc-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26 \
boost_date_time:${PORTSDIR}/devel/boost
RUN_DEPENDS= PTOptimizer:${PORTSDIR}/graphics/libpano12 \
PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -ftemplate-depth-64" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
USE_ICONV= yes
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
DOCSDIR= ${PREFIX}/share/hugin/xrc/data
-WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.6-config
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
@@ -45,7 +44,7 @@ PLIST_SUB+= NLS=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-wxrc|-${X11BASE}/bin/wxrc-gtk2-2.6|' \
+ @${REINPLACE_CMD} -e 's|-wxrc|-${WX_CONFIG:S/wx/wxrc/}|' \
${WRKSRC}/src/hugin/xrc/Makefile.in
.include <bsd.port.mk>