aboutsummaryrefslogtreecommitdiff
path: root/graphics/icoconvert/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/icoconvert/Makefile')
-rw-r--r--graphics/icoconvert/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/icoconvert/Makefile b/graphics/icoconvert/Makefile
new file mode 100644
index 000000000000..367a9af85e34
--- /dev/null
+++ b/graphics/icoconvert/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: icoconvert
+# Date created: Apr 30 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icoconvert
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.mox.net/downloads/
+
+MAINTAINER= flz@xbsd.org
+COMMENT= A small utility to convert Windows icon files into .xpm and .png files
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/icoconvert
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^icoconvert|all|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^\(FLAGS=\)|\1-I${PREFIX}/include |' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/icoconvert ${PREFIX}/bin
+
+.include <bsd.port.mk>